Finally got quad running again - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-13-2014, 08:00 PM Thread Starter
Junior Member
 
Join Date: Nov 2006
Posts: 21
Finally got quad running again

I have a 2004 raptor 350. I bought it about 9 years ago. Havn't had it running in 5 or more years. I just had my quad rebuilt. When I bought my quad it already had a GYTR slip on exhaust and then I added a stage one hotcam for a little performance boost.


With the recent rebuild the quad now has 84mm 11:1 weisco piston, head ported, new valves, new springs, hot rod crank, new rims and tires. Soon I will be adding a quicksilver edelbrock carb after I break in the new engine.

Going try and post some pics. Hope you guys like them.



Here are two pics from riding the other day.


2004 raptor 357, 11.1 wiseco piston, Hotrod crank/rod(stock length), stage 1 port, HotCams stage 1, KW valve HD springs, GYT-R exhaust, CFM airbox with Uni filter, Blue Hiper CF1 Beadlock Wheels GBC XC Master Tires
raptorjoe is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-02-2015, 11:01 PM
Senior Member
 
mr.pitts's Avatar
 
Join Date: Nov 2007
Location: Riverside CA
Posts: 261
Looks great. I dig the wheels!!!

07SE, SB, HR+5, HC3, CP11:1 SV Cuervo Head, ProDesign/Foam, PC3, DMC Force 4'S(Polished), Renthal bars, I-shock 2500, GT Thunder Link, JOGACA Dual Rate Shocks, Dura-Blue 2+2 FCI Tune


"Once you've tasted excess, everything else tastes bland." Nikki Sixx
mr.pitts is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Got it running again - Erattic idle? 700R Rider Raptor 700 Discussion 14 06-09-2013 07:04 PM
Finally got the graph...........finally! preddy08 Raptor 700 Modifications 41 04-12-2008 08:43 PM
finally getting a Quad again codyhcahoon YFZ 450 20 03-28-2008 03:28 PM
FINALY got it running right again. jet question. custom_bimmer Raptor 660 Modifications 11 01-27-2008 10:20 AM
Finally, finally, finally NixRaptor350 Off-Topic Lounge 96 06-09-2007 03:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome