seems to be running hot - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-10-2013, 01:27 PM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 37
seems to be running hot

did a oil nd filter change on my raptor 660 and it seems to be running a little hot or could it just be me or as any one had a problem like this

Put around 2.2ltrs in and its reading on full on the dip stick
thanks
Raptorblaster is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-10-2013, 01:47 PM
LJN
Lifetime VIP

 
LJN's Avatar
 
Join Date: Nov 2012
Location: Ypsilanti, MI
Posts: 921
Send a message via AIM to LJN
What makes you think it's running hot? give a full description of the symptoms.

2001 Raptor 660: Hot Cams 1, 101mm Wiseco 11:1 piston, 02 transmission update, Prodesign intake, K&N Powerlid, DMC Alien Dual(ish) Exhaust, DJ170/175, 25 pilots, Oversize radiator, Custom grill, YFZ450X Front Shocks, 450 front calipers, Jogaca rebuilt rear shock with KFX700 spring, DG bumper, ProTaper bars, TrailTech Vapor


1988 Warrior 350: 01 660 rear shock, Works DR remotes by Jogaca, DG Xcelerator, Cut plastics


1972 Hustler Amphibious 6x6: Runs!!


1986 Wife: Bone Stock
LJN is offline  
post #3 of 7 (permalink) Old 05-10-2013, 02:00 PM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 37
im just a panic sort of person and read some where if over you over fill then can course damage and over heat and the oil level should sit between low/full the quad was well over due a oil and filter change and i would think the temp light would come on if over heating
thanks
Raptorblaster is offline  
 
post #4 of 7 (permalink) Old 05-11-2013, 05:32 PM
Senior Member
 
nebraska_man660's Avatar
 
Join Date: Oct 2011
Location: nebraska
Posts: 180
The 660 motor naturally runs on the hot side.

'05 660
Wiseco 100mm 11:1 piston
HC stage 2 cam
-1F,+2R sprockets
Pro design intake kit w/ k&n filter. No airbox
LTE Duals
Jetted at 170R/165L 25 pilots
20" ITP sand stars on 8x8 Douglas blue labels
YFZ Shocks
Turner handlebars w/ Trail Tech bar clamp
Alba nerf bars
DG front and rear grab bars

'04 YFZ 450
Bone stock for now
nebraska_man660 is offline  
post #5 of 7 (permalink) Old 05-11-2013, 06:08 PM
I am unique

 
willykiller's Avatar
 
Join Date: Jun 2007
Location: Ottawa, Ontario
Posts: 22,612
Quote:
Originally Posted by Raptorblaster View Post
did a oil nd filter change on my raptor 660 and it seems to be running a little hot or could it just be me or as any one had a problem like this

Put around 2.2ltrs in and its reading on full on the dip stick
thanks
Quote:
Originally Posted by Raptorblaster View Post
im just a panic sort of person and read some where if over you over fill then can course damage and over heat and the oil level should sit between low/full the quad was well over due a oil and filter change and i would think the temp light would come on if over heating
thanks
First 660s don't naturally run hot. A few things to check are for dirty rad, inoperative thermostat, if you have an Aftermarket grille in front of the rad, leaking head gasket.
Before you panic check the engine temperature. Anything as high as 210 - 220 is okay.


686 three plugger with HV porting, 39 FCRS, Curtis Sparks exhaust, Dyna FS CDI
willykiller is offline  
post #6 of 7 (permalink) Old 05-11-2013, 07:49 PM
Senior Member
 
nebraska_man660's Avatar
 
Join Date: Oct 2011
Location: nebraska
Posts: 180
Quote:
Originally Posted by willykiller View Post
First 660s don't naturally run hot. A few things to check are for dirty rad, inoperative thermostat, if you have an Aftermarket grille in front of the rad, leaking head gasket.
Before you panic check the engine temperature. Anything as high as 210 - 220 is okay.
thought i read somewhere they run a little warm. i dont have a temp gage to justify what mine runs. my bad thanks for the correction.

'05 660
Wiseco 100mm 11:1 piston
HC stage 2 cam
-1F,+2R sprockets
Pro design intake kit w/ k&n filter. No airbox
LTE Duals
Jetted at 170R/165L 25 pilots
20" ITP sand stars on 8x8 Douglas blue labels
YFZ Shocks
Turner handlebars w/ Trail Tech bar clamp
Alba nerf bars
DG front and rear grab bars

'04 YFZ 450
Bone stock for now
nebraska_man660 is offline  
post #7 of 7 (permalink) Old 05-11-2013, 10:49 PM
Master of the Electron

 
QuadManiac's Avatar
 
Join Date: Apr 2007
Location: San Diego, CA
Posts: 14,422
If the fan works yet isn't coming on it's not hot... you're imagining too much.

AND - they don't run warmer or colder than any other - they run at exactly the temperature they were designed for. In addition, he Rappy's cooling system is more efficient than most.

'01 660 Raptor, Burgard +2+1 arms, YFZ Shocks, LSR anti-vibe, CTR pipe, jetted, K&N
'01 Polaris Scrambler 400, K&N
'02 Honda 400ex, Big Gun pipe, jetted, K&N, Lonestar +2 A-arms, Lonestar anti-vibe
'04 Suzuki LTZ400
'16 RZR XP4 1000 Turbo

Last edited by QuadManiac; 05-11-2013 at 10:51 PM.
QuadManiac is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Hot...Really Hot Limited660 General 660 Discussion 18 05-18-2011 08:44 PM
raptor seems like its getting hot really fast kjsimz1103 General 660 Discussion 11 03-02-2010 06:55 AM
rear end seems very hot? adkraptor General 660 Discussion 5 08-07-2009 09:09 AM
Anyone running the Yoshi system? Seems like a pretty good deal.... Lancester Raptor 700 Modifications 1 10-25-2006 12:02 PM
Suspension seems good for mx jumps what to adjust for better trail ridieng? akawilliam Raptor 660 Suspension 2 10-05-2006 09:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome