05 Raptor 660 No power. - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-30-2018, 03:08 PM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 1
05 Raptor 660 No power.

So I recently got a 05 raptor 660 I bought it non runing. The guy said it had no spark and then I realized it had no power at all. I replaced the stator and have great spark now and got a new battery for it. But even with the new battery no power still when I turn the key. I bought a new key switch and insalled it and still nothing. No lights or anything. I'm at sort of a dead end I'm not sure what to do at this point.
Colby Levesque is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-30-2018, 03:26 PM
Master of the Electron

 
QuadManiac's Avatar
 
Join Date: Apr 2007
Location: San Diego, CA
Posts: 14,416
Do any lights work? If not, check the fuse at the top of the starter relay, under the seat. Also check battery cables and connections for corrosion.

Welcome to the forum!

'01 660 Raptor, Burgard +2+1 arms, YFZ Shocks, LSR anti-vibe, CTR pipe, jetted, K&N
'01 Polaris Scrambler 400, K&N
'02 Honda 400ex, Big Gun pipe, jetted, K&N, Lonestar +2 A-arms, Lonestar anti-vibe
'04 Suzuki LTZ400
'16 RZR XP4 1000 Turbo
QuadManiac is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
dead raptor, no power, no lights, nothing peanutbutterscotch Raptor 700 Maintenance 6 02-18-2017 05:20 PM
03 660 no power to starter button and no spark over helpful under paided General 660 Discussion 11 01-16-2015 06:44 PM
05 raptor 350 no power at all EGcivic95 Raptor 350 Discussion 11 04-06-2013 08:03 AM
Big Problem, no start, no power, no fuel cycle, no neutral light 700gitrdone Raptor 700 Modifications 6 02-05-2009 06:30 PM
01 raptor started, now no noise, no start, no nothing calvinb General 660 Discussion 6 09-27-2008 10:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome