Idles fine, runs like crap! - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-22-2019, 04:18 PM Thread Starter
Member
 
Join Date: Mar 2018
Posts: 32
Idles fine, runs like crap!

I've got the 2004 raptor 660 and it is running horrible! Fires up no problem and idles just fine. It is when I rev it up a little that it starts to cut out and even backfire. When I put it in gear and try to go I' it doesn't do any of that but now it just wants to die.. anyone have any suggestions? Thank you!
bjhoeslang is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-24-2019, 07:00 AM
Member
 
Join Date: Jan 2017
Location: Southeast Wisconsin
Posts: 73
Go into the 660 maintenance discussion thread. The second sticky is common problems with the raptor 660.

I bet you'll find a few possible solutions in there.

The first thing I'd check, because it is super easy, is the parking brake. Go to the rear disk, make sure the arm (or lever) that moves when the brake cable is pulled is all the way in the released position.

There is a switch in there that makes your bike run like crap if it 'thinks' the parking brake is engaged.

Let us know what you find. It helps others.

Dale
Dale_W is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
04 raptor idles fine and runs good until i give it maybe 1/16 inch throttle bull346 General 660 Discussion 3 03-03-2019 03:33 PM
Help, raptor runs like crap. rynb15 Raptor 660 Maintenance 12 11-13-2008 10:11 PM
Runs like crap after wheelie KTM Danne Raptor 700 Modifications 10 04-03-2007 10:22 PM
bike runs like crap need help. sal Raptor 660 Modifications 20 03-19-2007 08:45 AM
06' 700 backfired, died then idles like crap for 10 or so min.... scott011422 Raptor 700 Discussion 12 10-03-2006 08:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome