Need help. Raptor 660 revving too high! - Yamaha Raptor Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 06-24-2019, 07:46 PM Thread Starter
Junior Member
 
KingSlaughter's Avatar
 
Join Date: Jun 2019
Posts: 20
Need help. Raptor 660 revving too high!

I just bought a 2003 raptor 660 a week ago. I’ve been loving it so much I’ve ridden it everyday. I’ve changed the plug, air filter, battery, and oil n filter will be here tomorrow. The things been riding like a beast but for some reason today it’s been riding bad, It idles fine, but when I go into first I automatically have to shift into 2nd if I go over about 5 mph and then 2nd to 3rd quickly so on and so forth. It was not doing this last week. I can’t help but think maybe rev limiter cause it did get stuck in reverse a few times I had to hit the shifter once more to get it to engage now it’s acting like there’s a rev limiter in every gear. I have no idea the bike is in immaculate condition for a 2003 the previous owner had it all stock and its been sitting for 3 years so how it runs so well I’m not sure but now this issue really has me uneasy I have no idea what it could be or what to do. Any help is greatly appreciated!
Attached Thumbnails
Click image for larger version

Name:	74CD4EA3-E8A5-4F99-83F7-3FED7A09C02A_1561423560090.jpg
Views:	23
Size:	125.2 KB
ID:	132905   Click image for larger version

Name:	4463B771-17B6-43B3-8F23-D7ABB4844DF2_1561423581424.jpg
Views:	23
Size:	44.8 KB
ID:	132907  
KingSlaughter is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 06-24-2019, 08:27 PM
Lifetime VIP

 
Join Date: Oct 2009
Location: Springfield, OR
Posts: 2,394
Send a message via AIM to t web2007
Quote:
Originally Posted by KingSlaughter View Post
I just bought a 2003 raptor 660 a week ago. I’ve been loving it so much I’ve ridden it everyday. I’ve changed the plug, air filter, battery, and oil n filter will be here tomorrow. The things been riding like a beast but for some reason today it’s been riding bad, It idles fine, but when I go into first I automatically have to shift into 2nd if I go over about 5 mph and then 2nd to 3rd quickly so on and so forth. It was not doing this last week. I can’t help but think maybe rev limiter cause it did get stuck in reverse a few times I had to hit the shifter once more to get it to engage now it’s acting like there’s a rev limiter in every gear. I have no idea the bike is in immaculate condition for a 2003 the previous owner had it all stock and its been sitting for 3 years so how it runs so well I’m not sure but now this issue really has me uneasy I have no idea what it could be or what to do. Any help is greatly appreciated!
Your title says revving too high yet your description says hitting rev limiter.
Is it revving high or hitting a limiter at low rpm?

The parking brake limiter would be my guess.

2015 700Rse
Fci, PC5F/I, monster exhaust, +2 Cuervo head, HDD5150, 54mm throttle body, 105.5 14:1, +8 swingarm.
08 yfz450se
Sparks big core, k&n no lid, yz needle, yz timing mod, +4 swingarm.
“Peepshow”
Cuervo 870, lectron, msd, monster megs, single a-arm lightened chasis, +14 swingarm.
”Monarchy”
Cuervo 930, lectron, msd, db fab titanium chasis.
t web2007 is offline  
post #3 of 12 (permalink) Old 06-24-2019, 09:21 PM Thread Starter
Junior Member
 
KingSlaughter's Avatar
 
Join Date: Jun 2019
Posts: 20
Quote:
Originally Posted by t web2007 View Post
Quote:
Originally Posted by KingSlaughter View Post
I just bought a 2003 raptor 660 a week ago. I’ve been loving it so much I’ve ridden it everyday. I’ve changed the plug, air filter, battery, and oil n filter will be here tomorrow. The things been riding like a beast but for some reason today it’s been riding bad, It idles fine, but when I go into first I automatically have to shift into 2nd if I go over about 5 mph and then 2nd to 3rd quickly so on and so forth. It was not doing this last week. I can’t help but think maybe rev limiter cause it did get stuck in reverse a few times I had to hit the shifter once more to get it to engage now it’s acting like there’s a rev limiter in every gear. I have no idea the bike is in immaculate condition for a 2003 the previous owner had it all stock and its been sitting for 3 years so how it runs so well I’m not sure but now this issue really has me uneasy I have no idea what it could be or what to do. Any help is greatly appreciated!
Your title says revving too high yet your description says hitting rev limiter.
Is it revving high or hitting a limiter at low rpm?

The parking brake limiter would be my guess.
So when I shift into 1st from N if I go about 5mph it revs like I’m holding throttle full open and it almost feels like it’s vibrating a little or running a little rough until I shift up then 2nd it rides okay but does it again at very low speeds all the way until 5th which then it rides pretty good but definitely doesn’t have all that raptor power I felt the first few days
KingSlaughter is offline  
 
post #4 of 12 (permalink) Old 06-24-2019, 09:23 PM Thread Starter
Junior Member
 
KingSlaughter's Avatar
 
Join Date: Jun 2019
Posts: 20
Quote:
Originally Posted by t web2007 View Post
Quote:
Originally Posted by KingSlaughter View Post
I just bought a 2003 raptor 660 a week ago. I’ve been loving it so much I’ve ridden it everyday. I’ve changed the plug, air filter, battery, and oil n filter will be here tomorrow. The things been riding like a beast but for some reason today it’s been riding bad, It idles fine, but when I go into first I automatically have to shift into 2nd if I go over about 5 mph and then 2nd to 3rd quickly so on and so forth. It was not doing this last week. I can’t help but think maybe rev limiter cause it did get stuck in reverse a few times I had to hit the shifter once more to get it to engage now it’s acting like there’s a rev limiter in every gear. I have no idea the bike is in immaculate condition for a 2003 the previous owner had it all stock and its been sitting for 3 years so how it runs so well I’m not sure but now this issue really has me uneasy I have no idea what it could be or what to do. Any help is greatly appreciated!
Your title says revving too high yet your description says hitting rev limiter.
Is it revving high or hitting a limiter at low rpm?

The parking brake limiter would be my guess.
Basically I have to shift wayyyy too early and it’s cause me to not get all my speed and power
KingSlaughter is offline  
post #5 of 12 (permalink) Old 06-25-2019, 11:06 AM
Lifetime VIP

 
Join Date: Oct 2009
Location: Springfield, OR
Posts: 2,394
Send a message via AIM to t web2007
Your clutch is toast.

2015 700Rse
Fci, PC5F/I, monster exhaust, +2 Cuervo head, HDD5150, 54mm throttle body, 105.5 14:1, +8 swingarm.
08 yfz450se
Sparks big core, k&n no lid, yz needle, yz timing mod, +4 swingarm.
“Peepshow”
Cuervo 870, lectron, msd, monster megs, single a-arm lightened chasis, +14 swingarm.
”Monarchy”
Cuervo 930, lectron, msd, db fab titanium chasis.
t web2007 is offline  
post #6 of 12 (permalink) Old 06-25-2019, 01:10 PM Thread Starter
Junior Member
 
KingSlaughter's Avatar
 
Join Date: Jun 2019
Posts: 20
Quote:
Originally Posted by t web2007 View Post
Your clutch is toast.
Really?! The clutch would dictate something like that? I have very little knowledge of these machines but I’ve been doing tons of research but okay that’s definitely something I can do if that’s it
KingSlaughter is offline  
post #7 of 12 (permalink) Old 06-25-2019, 11:30 PM
I may be getting older, but I refuse to grow up!

 
Join Date: Jun 2012
Location: PACIFIC N.W.
Posts: 10,109
Garage
I'm trying to understand. Does it rev up in gear by itself or when you give it throttle? If by itself you may have a vacuum leak. If in gear, adjust your clutch per your manual. But as said, it may be to late.

WELCOME TO THE FORUM.

'19 Can-Am X3, RS Turbo, 172 HP, 1300x15 STU #2 paddle, Tribute front, DynaTec controller, cat delete, GTP blow off valve, custom flame wrap, Bent Metal windshield, Blazer wiper, rear window, 48in LED light bar, 14in LED light bar, GTP LED side lights, S3 shock tower brace, aluminum rear pull plate, 5K Badlands winch, dual batteries, 5ft lighted whips, Rugged radio and intercom, interior lights, rock lights, chase lights, over $200 additional switches, YES, street legal with dirt tires.
DEZPERADO is offline  
post #8 of 12 (permalink) Old 06-26-2019, 06:17 AM Thread Starter
Junior Member
 
KingSlaughter's Avatar
 
Join Date: Jun 2019
Posts: 20
Quote:
Originally Posted by DEZPERADO View Post
I'm trying to understand. Does it rev up in gear by itself or when you give it throttle? If by itself you may have a vacuum leak. If in gear, adjust your clutch per your manual. But as said, it may be to late.

WELCOME TO THE FORUM.
Thank you sir glad to be here!
So as best as I can explain is I get on bike it idles fine and I’m in N when I shift to 1st and start to go everything’s fine until I’m completely off the clutch as I’m going I’m only at about 5mp and the Rpms are so high I have to shift up to bring them back down or release the throttle but as soon as I hit the throttle a little bit the rpms get way to high and I’m not going anywhere. It does that in every gear at low speeds until 5th where I’d say I max out at probably 60 so that power is not all there and in low gears I don’t have that crazy torque that kept almost throwing me off the bike the first few days now I control the thing like it’s my B**** and I’m only 130 lbs so I know something’s not right I do believe it is the clutch cause I think that would go hand with when I’ve put it into reverse 2 times it didn’t quite grab I had to shift down a time or 2 and I can hear some noises when it doesn’t grab reverse so I think that’s it I’m going to take the cover off this weekend and I’m praying it’s just the clutch.
KingSlaughter is offline  
post #9 of 12 (permalink) Old 06-27-2019, 04:02 AM
I may be getting older, but I refuse to grow up!

 
Join Date: Jun 2012
Location: PACIFIC N.W.
Posts: 10,109
Garage
Quote:
Originally Posted by DEZPERADO View Post
I'm trying to understand. Does it rev up in gear by itself or when you give it throttle? If by itself you may have a vacuum leak. If in gear, adjust your clutch per your manual. But as said, it may be to late.

WELCOME TO THE FORUM.
Adjust your clutch.

'19 Can-Am X3, RS Turbo, 172 HP, 1300x15 STU #2 paddle, Tribute front, DynaTec controller, cat delete, GTP blow off valve, custom flame wrap, Bent Metal windshield, Blazer wiper, rear window, 48in LED light bar, 14in LED light bar, GTP LED side lights, S3 shock tower brace, aluminum rear pull plate, 5K Badlands winch, dual batteries, 5ft lighted whips, Rugged radio and intercom, interior lights, rock lights, chase lights, over $200 additional switches, YES, street legal with dirt tires.
DEZPERADO is offline  
post #10 of 12 (permalink) Old 06-27-2019, 01:37 PM Thread Starter
Junior Member
 
KingSlaughter's Avatar
 
Join Date: Jun 2019
Posts: 20
Quote:
Originally Posted by DEZPERADO View Post
Quote:
Originally Posted by DEZPERADO View Post
I'm trying to understand. Does it rev up in gear by itself or when you give it throttle? If by itself you may have a vacuum leak. If in gear, adjust your clutch per your manual. But as said, it may be to late.

WELCOME TO THE FORUM.
Adjust your clutch.
I’ll try that and if nothing then I’ll open it up.
KingSlaughter is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome