why does my 30 amp fuse keep blowing - Page 4 - Yamaha Raptor Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 32 (permalink) Old 12-23-2013, 06:04 PM
Master of the Electron

 
QuadManiac's Avatar
 
Join Date: Apr 2007
Location: San Diego, CA
Posts: 14,409
Jack the thread? It's almost FIVE years dead, LOL...

Your problem has nothing to do with the fuse... check the RPM limiters (read the common 660 problems sticky.)

Can you get it to run above idle in the garage or on the way down the hilll, and only have problem getting above idle on the way UP the hill?

You're going to have to try to explain the symptoms in a little more detail - so far it only sounds as if you have the problem after you get the mail... and I'm sure that's not the case - be verbose about symptoms, chronology, what was wrong before, what engine work you had done, has it EVER run properly since the work... exactly what it's doing now, etc., etc.

What you are writing must take the place of our eyes - we can't see your quad.

'01 660 Raptor, Burgard +2+1 arms, YFZ Shocks, LSR anti-vibe, CTR pipe, jetted, K&N
'01 Polaris Scrambler 400, K&N
'02 Honda 400ex, Big Gun pipe, jetted, K&N, Lonestar +2 A-arms, Lonestar anti-vibe
'04 Suzuki LTZ400
'16 RZR XP4 1000 Turbo
QuadManiac is offline  
Sponsored Links
Advertisement
 
post #32 of 32 (permalink) Old 08-27-2019, 08:36 AM
Junior Member
 
Join Date: Aug 2019
Posts: 6
Great information shared.
DavisTremblay is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight Switch Keeps Blowing A Fuse. Why's That? Waynecarpenter Raptor 250 Discussion 5 09-19-2013 01:49 PM
Why do I keep blowing fuses? EricCoburn General 660 Discussion 6 03-19-2013 01:32 AM
Keeps Blowing 30 Amp Fuse boatmanloto General 660 Discussion 4 02-28-2010 08:45 AM
blowing main fuse bad rectifier???? 1qwkgoat Raptor 700 Discussion 5 08-29-2007 08:24 AM
Raptor 80 main fuse keeps blowing out atvforever Raptor 90, 80 and 50 1 08-23-2007 02:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome