Help! 660R problem at high revs - Yamaha Raptor Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 95 (permalink) Old 12-07-2010, 06:17 PM Thread Starter
Member
 
Join Date: Dec 2010
Posts: 42
Help! 660R problem at high revs

Hi just recently bought a 660 raptor (2 days ago), having a huge problem with it.

When idle in neutral bike is fine and also seems ok when being revved at high revs.

The problem is as soon as I put the bike into gear and set off the bike more or less cuts out at around I would say roughly 2000 - 2500 revs and sputters until I change gear.

I can physically not get passed around 65mph and this is a big problem for me.

I had a quick look at the most common problems thread and just wondered if the quad would still have problems when in neutral revving up which my quad does not if it either of the limiters? Also I have not noticed any backfiring.

The quad does have a yoshimura end can only so unsure if it could cause anything significant like this.

I'm a complete novice when it comes to this sort of thing and all help would be appreciated thanks guys.
Brookie is offline  
Sponsored Links
Advertisement
 
post #2 of 95 (permalink) Old 12-07-2010, 06:26 PM
Junior Member
 
Join Date: Jul 2010
Posts: 9
https://www.raptorforum.com/forums/sh...ad.php?t=60922

a lot of time was spent on this thread for these purposes, thanks QM!

BUT since I'm typing, the parking brake sensor would be my first guess; disconnect and rewire back to itself. DONE.
nappahdog is offline  
post #3 of 95 (permalink) Old 12-07-2010, 06:55 PM
Senior Member
 
HALFFAST's Avatar
 
Join Date: May 2008
Location: Cinci, Oh
Posts: 191
I can physically not get passed around 65mph and this is a big problem for me.[/QUOTE]


**04 RAPTOR 660**
Wiseco 11:1
Megacycle X4
Barker head
+1 Ferreas
Monster Duals
39 FCRs
Dynatek FS
+4 axle
+2 up 1 a-arms
Custom 3 1/2" swinger
YFZ 450 shocks
YFZ 450 brakes
HALFFAST is offline  
 
post #4 of 95 (permalink) Old 12-07-2010, 07:48 PM
Master of the Electron

 
QuadManiac's Avatar
 
Join Date: Apr 2007
Location: San Diego, CA
Posts: 14,440
THe bike tops out at 75 normally... 65 is pretty close. I think a little more detail in the symptoms are going to be necessary to debug this. Perhaps you are just jetted a little lean?

'01 660 Raptor, Burgard +2+1 arms, YFZ Shocks, LSR anti-vibe, CTR pipe, jetted, K&N
'01 Polaris Scrambler 400, K&N
'02 Honda 400ex, Big Gun pipe, jetted, K&N, Lonestar +2 A-arms, Lonestar anti-vibe
'04 Suzuki LTZ400
'16 RZR XP4 1000 Turbo
QuadManiac is offline  
post #5 of 95 (permalink) Old 12-07-2010, 07:53 PM
I am unique

 
willykiller's Avatar
 
Join Date: Jun 2007
Location: Ottawa, Ontario
Posts: 22,612
Give us a list of your mods and jetting specs and we can tell you if you are close to where it should be..............
I think it is jetting related...........


686 three plugger with HV porting, 39 FCRS, Curtis Sparks exhaust, Dyna FS CDI
willykiller is offline  
post #6 of 95 (permalink) Old 12-08-2010, 02:11 AM Thread Starter
Member
 
Join Date: Dec 2010
Posts: 42
Unsure

I don't think I was clear enough, what I mean is the quad literally dies at high revs and then comes back on and off jerking the bike as it does so, it may be close to topping out at 75 if thats what the top speed is on these things but to physically get there I have to change gear at around 2500rpm or the power just disappears and the bike sputters as the bikes revs go up and down nearing this level.

if the parking brake limiter is the problem would the bike still rev out in neutral, I will check this though to eliminate the possibility thanks for the replys guys.

Is it more likely to be parking brake limiter or reverse limiter? I'll check the parking break limiter first as it seems easier to check?

Last edited by Brookie; 12-08-2010 at 02:22 AM. Reason: Adding to post
Brookie is offline  
post #7 of 95 (permalink) Old 12-08-2010, 02:19 AM Thread Starter
Member
 
Join Date: Dec 2010
Posts: 42
As far as I know

As far as I know the only thing changed is the end can, which is a yoshimura off road can, I don't know the size of the jets, I would assume they are factory standard as everything else on the bike is standard, this is a road legal 2004 660r, the can just makes it sound ridiculouly loud. thanks again
Brookie is offline  
post #8 of 95 (permalink) Old 12-08-2010, 06:12 AM Thread Starter
Member
 
Join Date: Dec 2010
Posts: 42
Got rev counter working

Hi I was wrong about the rev cut out point, the quad is pretty much cutting out and losing all power at around 4500 to 5000 revs.

This might seem not too bad but I mean literally all power is gone and causes the bike to pretty much cut out, its not like its just redlining its just cuting out until it gets under this point, I can get no real power out of this thing and its driving me crazy.

When it is in neutral and i rev the engine it will redline at around 7000 rpm which seems reasonable?

It does not cut out when in neutral only limits the power from going any higher. What is the most probable cause of this?

Another thing I would like to add is that the reverse gear has been disabled by the previous owner, could this be part of the problem with the reverse limiter?

Sorry for all the stupid questions I just know absolutely nothing about these things. Thanks

Last edited by Brookie; 12-08-2010 at 07:23 AM.
Brookie is offline  
post #9 of 95 (permalink) Old 12-08-2010, 07:27 AM
I am unique

 
willykiller's Avatar
 
Join Date: Jun 2007
Location: Ottawa, Ontario
Posts: 22,612
Quote:
Originally Posted by Brookie View Post
Hi I was wrong about the rev cut out point, the quad is pretty much cutting out and losing all power at around 4500 to 5000 revs.

This might seem not too bad but I mean literally all power is gone and causes the bike to pretty much cut out, its not like its just redlining its just cutting out until it gets under this point, I can get no real power out of this thing and its driving me crazy.

When it is in neutral and i rev the engine it will redline at around 7000 rpm which seems reasonable?

It does not cut out when in neutral only limits the power from going any higher. What is the most probable cause of this?

Another thing I would like to add is that the reverse gear has been disabled by the previous owner, could this be part of the problem with the reverse limiter?

Sorry for all the stupid questions I just know absolutely nothing about these things. Thanks
Again I say, check your jetting and give us a list of the jetting specs, pilots jets, needles and their position and the size of the main jets........
Also a complete list of the mods done to it including the intake system and exhaust.............


686 three plugger with HV porting, 39 FCRS, Curtis Sparks exhaust, Dyna FS CDI
willykiller is offline  
post #10 of 95 (permalink) Old 12-08-2010, 09:29 AM
Lifetime VIP

 
maxtrax's Avatar
 
Join Date: Jul 2009
Location: Appleton, WI - 800ft ASL
Posts: 2,359
Garage
What gearing are you running? If you have it geared lower then you will not be able to go as fast. This will make the speed limiter kick in faster.


2007 700-
11:1 Wiseco piston, +5 HR crank, Lucky700R ported head, HDD5050 cam, +3TB, DMC Force IV duals, MSD Blaster FI controller, UNI pod filters, ITP Beadlock rims + more

2001 Raptor-
100.5mm 11:1 Wiseco piston, balanced crank, trail ported head, Ferrea valves, stage 2 HC, Barker duals, UNI pod filters + more

2007 pitbike-
150cc Lifan engine, 26mm Mikuni carb, 32mm custom stainless steel exhaust, 12" motard tires, working on LED
maxtrax is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
04 raptor 660r revs fine in neutral but not in gear. Bogging? Ehh.. thearchangel16 General 660 Discussion 2 10-23-2012 10:03 PM
Dies out at high revs Wehrwolf Raptor 660 Maintenance 19 09-12-2011 07:11 AM
High revs spitting villitheo Raptor 700 Maintenance 1 02-19-2011 05:25 PM
Clutch cable tension, motor revs high marshview ripper Raptor 700 Modifications 2 03-12-2008 11:18 PM
my 05 raptor is making a funny nosie AT HIGH REVS damotyrer General 660 Discussion 5 02-24-2008 07:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome