Brake light always on - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-22-2014, 01:14 PM Thread Starter
Valued Member

 
DustyRappy's Avatar
 
Join Date: Oct 2012
Location: Pretoria, South Africa
Posts: 625
Send a message via Skype™ to DustyRappy
Brake light always on

I have a 660 whose brake light is permanently on.
Can anyone give me a couple of things to check on tomorrow?
I'm not really going to be able to test and report due to the time difference.
And I need to solve it pretty quickly.

Thanks guys.

________________________________________
2007 700R SE. DMC Force 4 Duals, Prodesign billet adapter and foam filter, PCV with AutoTune. Precision Pro Stabilizer. Alba +2 A-Arms. Elka Stage 5 all round. Fasst Flexx bars. ASV black levers. ODI Rogue lock-ons. Racestars anti-vibe bar risers. Hiper Tech 3 with Maxxis Razr2.

Waiting to be installed:
+5mm Hotrods crank
Stock ported head.
Hotcam Stage 3.
CP 11:1 piston.
+3TB.
Driveline Performance Clutch.
DustyRappy is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-22-2014, 01:22 PM
I may be getting older, but I refuse to grow up!

 
Join Date: Jun 2012
Location: PACIFIC N.W.
Posts: 10,019
Garage
The switch is right off the brake pedal. There should be a spring to actuate it. Be sure the switch operates properly, and is adjusted properly.
DEZPERADO is offline  
post #3 of 8 (permalink) Old 06-22-2014, 01:46 PM
www.gtpoffroad.com
 
Rap_Rider's Avatar
 
Join Date: Nov 2011
Location: Las Vegas
Posts: 2,576
I'd start with the brake switches for sure and the rear brake one first.

08 Raptor 700r - March 2013 ROTM

DMC Force 4 Duals - FCI Intake - PC5/Autotune - Stage 3 Hotcam - 12:1 CP Piston - +3 Cuervo TB - Ported head - Kibblewhite springs

Elka Stage 4 - Houser +2.25" MX LT MGC A-Arms - Lone Star Axle (+6)

Pro Armor Skid Plate - Pro Armor Nerf Bars

GTP Beadlock Wheels - Skat~Trak 9 paddle

ProTaper Contour Bars - Trail Tech Bar clamps - ODI grips - Fastway Steering stabilizer - Vapor

My Videos: http://www.youtube.com/user/DJraprider?feature=guide
Rap_Rider is offline  
 
post #4 of 8 (permalink) Old 06-22-2014, 03:52 PM
I may be getting older, but I refuse to grow up!

 
Join Date: Jun 2012
Location: PACIFIC N.W.
Posts: 10,019
Garage
Quote:
Originally Posted by DEZPERADO View Post
The switch is right off the brake pedal. There should be a spring to actuate it. Be sure the switch operates properly, and is adjusted properly.
Test the brake switch on the handlebars front brake lever. If it's not the switches, you may have a shorted wire.

Yep, you're out of time. When do you leave?? Good luck, have a good time!!
DEZPERADO is offline  
post #5 of 8 (permalink) Old 06-23-2014, 03:16 AM Thread Starter
Valued Member

 
DustyRappy's Avatar
 
Join Date: Oct 2012
Location: Pretoria, South Africa
Posts: 625
Send a message via Skype™ to DustyRappy
Thanks for the ideas guys.
It was an easy fix. The plate on the rear brake pedal where the spring fastens was bent down. Permanently pulling on the spring. It actually looked like it could have been made that way, until I compared it to one of my others.




________________________________________
2007 700R SE. DMC Force 4 Duals, Prodesign billet adapter and foam filter, PCV with AutoTune. Precision Pro Stabilizer. Alba +2 A-Arms. Elka Stage 5 all round. Fasst Flexx bars. ASV black levers. ODI Rogue lock-ons. Racestars anti-vibe bar risers. Hiper Tech 3 with Maxxis Razr2.

Waiting to be installed:
+5mm Hotrods crank
Stock ported head.
Hotcam Stage 3.
CP 11:1 piston.
+3TB.
Driveline Performance Clutch.
DustyRappy is offline  
post #6 of 8 (permalink) Old 06-23-2014, 03:17 AM
GARAGE CULTURE

 
Pacific Barbarian's Avatar
 
Join Date: Jul 2009
Location: Kalahari Desert, South Africa
Posts: 3,723
Glad you got it quickly.

The front light should be there today I think?

Sent from my GT-P7500 using Tapatalk 2

2009 Raptor 700.
Powercommander 5 with DL700 Timing Curves, FCI with Box, HD5050, +5 Hotrods, Ported Head +2 +1 by Freez, CP 11:1, +3 Throttle Body, DMC Force 4, Lonestar Swingarm, Houser MGC LT +2.25, Custom Axis LT Triple Spring Triple Adjust with Plush Ride Upgrade Front, Custom Axis Double Spring Triple Adjust with Plush Ride Upgrade Rear, Hipertech 3, Kenda Bearclaw, Fasst Flexx, Precision Pro Steering Damper, Lonestar Axle.
Pacific Barbarian is offline  
post #7 of 8 (permalink) Old 06-23-2014, 05:14 AM Thread Starter
Valued Member

 
DustyRappy's Avatar
 
Join Date: Oct 2012
Location: Pretoria, South Africa
Posts: 625
Send a message via Skype™ to DustyRappy
Quote:
Originally Posted by DEZPERADO View Post
Test the brake switch on the handlebars front brake lever. If it's not the switches, you may have a shorted wire.

Yep, you're out of time. When do you leave?? Good luck, have a good time!!
I leave on Friday. We have a 4 hour drive to where it starts. The actual ride starts on Saturday. I'm a little pushed for time especially seeing as though I decided to do some work on my small trailer as well.

Quote:
Originally Posted by Pacific Barbarian View Post
Glad you got it quickly.

The front light should be there today I think?

Sent from my GT-P7500 using Tapatalk 2
I'm hoping so. Our wonderful postal service. Chances are you will be here before the light and the light had a 2 week head start.

________________________________________
2007 700R SE. DMC Force 4 Duals, Prodesign billet adapter and foam filter, PCV with AutoTune. Precision Pro Stabilizer. Alba +2 A-Arms. Elka Stage 5 all round. Fasst Flexx bars. ASV black levers. ODI Rogue lock-ons. Racestars anti-vibe bar risers. Hiper Tech 3 with Maxxis Razr2.

Waiting to be installed:
+5mm Hotrods crank
Stock ported head.
Hotcam Stage 3.
CP 11:1 piston.
+3TB.
Driveline Performance Clutch.
DustyRappy is offline  
post #8 of 8 (permalink) Old 06-23-2014, 04:51 PM
I may be getting older, but I refuse to grow up!

 
Join Date: Jun 2012
Location: PACIFIC N.W.
Posts: 10,019
Garage
Quote:
Originally Posted by DustyRappy View Post
Thanks for the ideas guys.
It was an easy fix. The plate on the rear brake pedal where the spring fastens was bent down. Permanently pulling on the spring. It actually looked like it could have been made that way, until I compared it to one of my others.
Once again, I like a easy fix. Why is it things to do, increases in number when its time to go??
DEZPERADO is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
01 660r temp light always on redneck2001660r General 660 Discussion 8 10-06-2010 02:44 PM
petrol light always on Raptor Gsy Raptor 700 Discussion 1 04-19-2010 09:07 PM
Neutral light, always on?? jmeccia Raptor 700 Discussion 3 07-10-2009 02:44 PM
Few problems after ride, low fuel warning light always on, Trail Tech going nuts Tiggyboot Raptor 700 Discussion 3 04-01-2007 12:52 PM
Got 2 skull led tag light mounts can I get help tapping into brake light wires? akawilliam Raptor 660 Maintenance 1 10-13-2006 09:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome