Raptor 660 Won’t Start! help! - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-18-2019, 06:37 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 1
Raptor 660 Won’t Start! help!

I have a 2002 Raptor 660 limited edition, It was working, I was riding it, occasionally I had issues with the electric start button, so I tap it with a knife and it will start up, well I was riding it and it just cut off on me, so I pressed the button to start it, at first it would crank halfway (like the battery was low) wouldn’t crank, then I smelt some type of burning I thought maybe something shorted out under the seat where the battery is, so now when I press the start button the temp light comes on, neutral light on, don’t hear any click; but can feel a slight tap in the starter relay, I tried to jump the battery, the battery is good, it does the exact same thing. I checked positive/negative on the starter relay, it sparks, same as the battery. So I don’t think it’s any connections there, anybody have any clue what is wrong with my four wheeler?
Wayneo94 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-25-2019, 12:23 AM
Junior Member
 
Join Date: Jul 2019
Posts: 4
May have melted some wiring? Trace the starter button wires and starter wires. Secondly try and jump the solenoid under the seat with a wrench and if that turns over the motor and makes it fire. That’ll give you a good sense whether or not the starter fried itself
Kevin McGinitie is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome