Fuel Pump won't come on... - Yamaha Raptor Forum
 1Likes
  • 1 Post By 700craptor
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-09-2017, 08:13 PM Thread Starter
Junior Member
 
Join Date: Jul 2017
Posts: 2
Fuel Pump won't come on...

I have a 2006 Raptor 700R that won't start. It hasn't ran in a couple of years but has been garaged. I drained all fuel and replaced it with ethanol free and a little sea foam. I replaced battery and spark plug and checked the air filter. I cannot hear the fuel pump prime when I turn the key (I've been told that you should be able to hear it prime). I also disconnected the fuel line from the pump and no fuel comes out when I push start. I disconnected the cable from the fuel pump and read for VDC. On 2 of the wires I got 12VDC with the key turned on. On the other 2 wires I got 12VDC when I push the start button. The electrical appears to be working fine. I bought a new fuel pump and installed it. Still wouldn't start so I checked the wires going from the pump itself to the plug on the plastic housing and one was bad so I replaced both of them as well. It's still not starting so I'm thinking maybe it has something to do with whatever the other 2 wires go to (not sure of the part name). It's a small silver cylinder that looks pretty corroded and what appears to be some kind of grounding post that one of the wires is attached to. Can anyone identify this part for me and let me know if that would cause my fuel pump not to prime and work properly? Thanks.
Attached Thumbnails
Click image for larger version

Name:	IMG_5139.JPG
Views:	125
Size:	175.9 KB
ID:	121586  
Nate Kuwitzky is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-09-2017, 08:29 PM
POTW Moderator

 
Join Date: May 2012
Location: Northern Colorado
Posts: 7,621
Garage
Welcome to the forum,

Make sure you have the run switch on, it won't prime if that is off.

[U]2006 raptor 700

DMC Force 4's, FCI W/box, Dynatek Fusion,
CP 11:1 piston, BaMotorsports porting, HC3
RacersEdge +3TB
YFZ 450 fronts & reworked rear by JOGACA
Trailtech 1 1/8 xbar w/vapor dash & Vapor installed
ODI Rogue grips & ASV pro pack levers
Fastway steering stabilizer
68HP 49TQ

PM me if you need service manuals
morphrider is offline  
post #3 of 7 (permalink) Old 07-09-2017, 08:50 PM Thread Starter
Junior Member
 
Join Date: Jul 2017
Posts: 2
Yes I have the run switch on and I am pressing start. The engine cranks but won't start because it isn't getting fuel.
Nate Kuwitzky is offline  
 
post #4 of 7 (permalink) Old 07-12-2017, 11:27 AM
Junior Member
 
Join Date: Mar 2017
Location: Shoals, IN
Posts: 28
I rebuilt my 09 raptor fuel pump and mine is a little different then that. What I would do if I was you would be disassembly it, clean all connections, and put it back together. If it doesn't fun you can buy just the pump itself for 90 dollars from HighFlowFuel I believe is the name i bought mine from. The complete assembly is about 385 for a new one. So saves a lot of money and simple to do.
Jake Wallisa is offline  
post #5 of 7 (permalink) Old 07-13-2017, 10:33 AM
Senior Member
 
Andon Jones's Avatar
 
Join Date: Oct 2014
Location: NM
Posts: 689
Garage
early 06 raptor 700s had a recall for the vapour gate on the pump was too small and it would clog up and cause the pump to seize if I am remembering right. But I would take it all apart and clean it; was there gas sitting in the tank for a while?

Andon Jones AKA Jones m4n117

06 Raptor 700r 50th ed
-GYTR exhaust and intake, Pro Design Uni (THANK YOU Santa DEZ! ),YFZ fronts and 700r rear all done the the "King Of The Spring" Jogaca!! ,PC3 ,TUSK nerf bars,GBC XC-Masters rear and fronts,AC racing bumper,6000k Bi-Xenons,trail tech bars,ODI grips,TUSK hand guards, and the best graduation present ever!

If you feel like watching some Raptor vids take a look!

https://www.youtube.com/channel/UCJZ...3HMTWOG6OgX6Fw
Andon Jones is offline  
post #6 of 7 (permalink) Old 07-13-2017, 08:39 PM
Lifetime VIP

 
700craptor's Avatar
 
Join Date: Sep 2010
Location: Spruce Grove, AB.
Posts: 1,096
He said he got a new pump.
Andon Jones likes this.

>Fast flex bars>Rox Antivibe>Pillow Soft Grips>A/C Front Bumper>PRM 6 Pack Rack>GYTR Nerfs >GYTR skids>Barker Duals>ARP Headstuds>CP 11.5:1 Tech Piston>FCI>PCV/Ignition/Autotune>DL700's Timing Curve>Stage 4 elkas triple rate LT>+2 houser LT>Speed sensor hack>15 T front sprocket>Clutch Plate Mod&HD springs>Cuervo +1 ported head>+3 TB>DL's 5050 cam>Elka Stage 4 Dual rate rear>+3 Swinger>Alba +4 axle>72.9 hp & 61.5 [email protected] front sprocket
700craptor is offline  
post #7 of 7 (permalink) Old 10-09-2019, 06:19 AM
Junior Member
 
KingFab's Avatar
 
Join Date: Sep 2019
Posts: 12
Continuance. Please.

Same issue on an 07.

Old thread/topic I understand, but we want up to date answers/follow-ups..

Old Threads/ 3rd parties mention:
“Check all electrical in pump assembly”
“The ground and some other wire may need assistance where they come through there connectors or at termination points”
(reported on youtube “cheap repair videos”)
“Check the Lean angle” (if no spark too)
“If you have sacrificial bike try new harness”(workd for some dude n2010)
KingFab is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Low fuel light won't come on? traut811 Raptor 700 Maintenance 1 04-22-2012 12:28 AM
can the stock fuel pump pump enough fuel for methanol?? cody61406 Raptor 700 Modifications 13 08-21-2011 11:53 AM
GEORGIA RIDE DAY.. COME ONE COME ALL rap7hundred Rider Locations / Meets 94 11-13-2007 08:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome