starter witch doesn't start - battery fine - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-24-2019, 08:38 AM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 2
starter witch doesn't start - battery fine

been trying to diagnose electrical problem. Raptor 90 2017

When press the starter button, nothing happens. No click, no power. It is like the button wasn't pressed. When kickstart it works fine and key and kill switch both work fine.

Replaced the starter relay and same problem. All connections seem good. Opened up the case where the starter button is and noticed the spring used was not retaining its form so provided no push resistance, so replaced it with another spring (trimmed a copper spring I had). Spring looks like it makes good contact so I don't think the spring is the issue.

If I pull the starter relay, I can put in a jumper and start it so I know the battery is fine. Using a simple electric tester, doesn't seem to have any power coming out of the relay, but I'm not sure it is supposed to.

Any ideas?
tdenbow is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-24-2019, 08:48 AM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 2
also checked fuse, and fuse is fine.
tdenbow is offline  
post #3 of 3 (permalink) Old 06-24-2019, 12:10 PM
Senior Member
 
4stroker4life's Avatar
 
Join Date: Jul 2017
Location: SW Missouri USA
Posts: 1,633
I had a similar issue last year. I had replaced my starter solenoid with a cheap one from ebay because i didnt want to pay $60 for oem. I installed it just like my old one came out. Didnt notice that the chinese relay had reverse polarity until i looked closely at the letters on it. Turned it around and everything was fine. Just a thought...

Also, does the 90 have any safety switches that could be the problem? On the bigger ones they wont start in gear without the clutch pulled

Sent from my SM-G920V using Tapatalk

07' Raptor 700- 11:1, hotcam 3, Pro design intake with K&N, +3 throttle body, Monster big bore duals, MSD with cuervo timing, JOGACA shocks, trail tech VAPOR, GYTR heel guards & bumper & nerfs, .250 aluminum skids, TM case saver, folding anodized levers and shifter, powermadd hand guards

04' raptor 660-Hot rods crank, .5mm overbore, 11:1 wiseco piston, Stage 1 hotcam, Yoshimura slip-on exhaust, K&N filter with outerwears, open lid airbox, Dynojet stage 2 jet kit
4stroker4life is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome