Check engine light when pressing start - Yamaha Raptor Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-03-2019, 07:59 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 5
Question Check engine light when pressing start

Hello.. I have a 19 Raptor 700 with probably 8hrs. I read a topic where the best beak-in steps are ride it as you will always ride. there has been several times where I ride wide open and some times I ride trails on a slow pace. well today I got stock on a deep hole with water and the bike shut off. I turn it back on and continue riding as normal, but the second time I turn it on when pressing the ignition starter the check engine light illuminates solid, but only when pressing the start button, after the bike is on it never appears back again. what could that be? Also I went to the street an got it to 5th gear and when lowering the gears down it backfired twice. bike is 100% stock. very weird.
mcirving is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-03-2019, 08:11 PM
Senior Member
 
Team 2 gils's Avatar
 
Join Date: Dec 2017
Posts: 256
Depending on how deep that water was, I would check your electrical connectors and make sure they are dry. If the water was over the engine, check your oil and make sure no water is in there.
Team 2 gils is offline  
post #3 of 4 (permalink) Old 03-03-2019, 08:43 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 5
not too deep, a little lower than the oil filter cap. It shut off probably because I was on 3rd and didn't hit the clutch on time, but thatīs a good one, I will check some electrical connections tomorrow. I was reading other post a few minutes ago and saw that the same light comes on to others but they donīt bother. I do because that was not happening before todayīs ride .
mcirving is offline  
 
post #4 of 4 (permalink) Old Yesterday, 10:04 AM
Junior Member
 
Join Date: May 2019
Posts: 6
Thanks all for your replies. . .
HarryCallum111 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressing off reverse gear John Christopher Tynski General 660 Discussion 0 04-11-2016 01:53 PM
Check engine light and no start reddragon444 Raptor 700 Maintenance 3 12-01-2014 05:43 PM
reset check engine light rvrrappy Raptor 700 Maintenance 3 02-03-2007 01:48 PM
check engine light questions. supraman23 Raptor 700 Modifications 13 10-31-2006 10:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome