Yamaha Raptor Forum - Reply to Topic
Thread: Steering Stem (Alba Racing); underside bolt size Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Yamaha Raptor Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-16-2019 09:54 AM
TorchTarga94
Quote:
Originally Posted by Chance Moto View Post
Hey guys. Silly question -I just installed the Alba +1.5 steering stem and the underside bolts (that secure the clamp to the stem) are rubbing against the tank plastics near full lock. Am I doing something wrong or has anyone else experienced the same issue?
I had the exact same issue on my 06'. Live with it or trim the bottom of the bolts off with a dremel/die grinder. It shouldn't be the nuts hitting the tank cover, just the leftover section of the threaded antivibe bolts.
09-14-2019 07:05 PM
Chance Moto Hey guys. Silly question -I just installed the Alba +1.5 steering stem and the underside bolts (that secure the clamp to the stem) are rubbing against the tank plastics near full lock. Am I doing something wrong or has anyone else experienced the same issue?
08-08-2018 01:59 AM
mcclelland32
Quote:
Originally Posted by drwinlied View Post
Sadly, M5 x .8 don't thread in. Alba isn't helping either. I'm going to just start buying random ones I guess. However, I feel the m5 x .8 was close...so thanks for getting me that far, at least
Huh... I have two alba +2 stems and the m5 x.8 threaded into both as I checked both before I replied. Well glad you got it figured out.
08-07-2018 08:31 PM
drwinlied I'm just going to go ahead and triple post up in this bish.

I FOUND THE RIGHT SIZE!! For the Alba steering stem, what you need are 10-32x1/2 and so concludes this adventure. Thank you @mcclelland32 for the relocate plate! I've already dremeled it up so it works fine.
08-07-2018 02:52 PM
drwinlied
Quote:
Originally Posted by mcclelland32 View Post
easy day... M5x.8 if your talking about the two bolt holes that would be used for... say a key relocate plate
Sadly, M5 x .8 don't thread in. Alba isn't helping either. I'm going to just start buying random ones I guess. However, I feel the m5 x .8 was close...so thanks for getting me that far, at least
07-27-2018 03:43 PM
drwinlied YAS! PM sent
07-27-2018 03:01 PM
mcclelland32 Do you have a key relocate plate already? I have an aluminum one I can send to you just pay shipping. If your interested let me know.
07-27-2018 11:07 AM
drwinlied
Quote:
Originally Posted by mcclelland32 View Post
easy day... M5x.8 if your talking about the two bolt holes that would be used for... say a key relocate plate
Man, if I could like that more than once, I certainly would. THANK YOU! I mean, I was just going to zip-tie the key ignition to the steering stem...but I think this might work out better in the long run haha
07-26-2018 11:19 PM
mcclelland32 easy day... M5x.8 if your talking about the two bolt holes that would be used for... say a key relocate plate
07-26-2018 12:30 PM
drwinlied
Steering Stem (Alba Racing); underside bolt size

First off, I know this is a long shot, but I'll give it the ol' college try.

Does anyone know what size bolt threads into the underside of an Alba Racing Steering stem (at the top)? On the underside of the header, which the handlebar mounts bolt to, there are two tiny bolt holes for mounting a bracket, I'm sure. I imagine these would be standard across all Alba stems, at least. I didn't see the holes until the stem was mounted and the atv was all back together (otherwise I just would have brought the stem to the hardware store and tried everything until I found the right one).

I'll get a picture here in a bit. My explanation is poor, at best.

Well, I tried to upload a pic, but it keeps failing. gawd! lol

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome