Raptor Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2001 660 raptor I need help with. I tried to start it up when I hit the start button it backfired extremely loud blew the carbs off, so I put the carbs back on and it sounded fine while I try to start it for a couple tries then it started to turn over a lil faster and the compression seems to not be what it was I think plus I have gas draining out the back of the carbs. Can anybody help me? I don't want to rip motor apart if it could be carbs or the other way around
 

·
Registered
Joined
·
197 Posts
I think its your carbs. Especially if their leaking out gas. I would rebuild the carbs according to the Yamaha service manual. I believe you can download it somewhere on this forum. Cant remember where though. Check to make sure your spark plug is fully seated too.
 

·
~~~ 660 Specialist ~~~
Joined
·
933 Posts
if theres gas pouring out of the overflows on the carbs then ur float valve inside the carbs is bad or just needs a lil cleaning.....they r very finiky, I would pull the carbs and clean very good, all the jets and everything.....
 

·
I am unique
Joined
·
22,621 Posts
I have a 2001 660 raptor I need help with. I tried to start it up when I hit the start button it backfired extremely loud blew the carbs off, so I put the carbs back on and it sounded fine while I try to start it for a couple tries then it started to turn over a lil faster and the compression seems to not be what it was I think plus I have gas draining out the back of the carbs. Can anybody help me? I don't want to rip motor apart if it could be carbs or the other way around
Dismantle and clean your carbs, set the floats to the proper level and check the needle and seats............
 

·
Registered
Joined
·
49 Posts
I have a 2001 660 raptor I need help with. I tried to start it up when I hit the start button it backfired extremely loud blew the carbs off, so I put the carbs back on and it sounded fine while I try to start it for a couple tries then it started to turn over a lil faster and the compression seems to not be what it was I think plus I have gas draining out the back of the carbs. Can anybody help me? I don't want to rip motor apart if it could be carbs or the other way around

You didn't mention if it ran before.Has it been sitting a long time?It seems you have 2 issues.You do need to look at the carbs.But if it seems to have low compression suddenly,I would suspect you got something under a valve.Possibly introduced while the carb was blown off.Or possibly,when it backfired,you could have jumped a tooth or three on the cam timing chain.
 
1 - 5 of 5 Posts
Top