Raptor Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey I have a 03 raptor 660, I was at sand fest in little sahara got stuck at on an incline and I poped the clutch out in first raping into second and got to the top. But when I got up there I noticed a uneasy noise coming from my front top end like a tink or chatering sound. My buddy thinks I need valves adjusted I took an easy riding back in. But even quarter throtle it was bad sounding and idle in N as well. I would greatly appreciate any advise anyone has to offer thanks!
 

·
Registered
Joined
·
54 Posts
There is a sticky on how to adjust your valves, you can start there. Also, if you can post a video of the bike running (with sound) on YouTube with a link here it would be helpful to those more knowledgeable than myself to help you diagnose it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Alright it still hasn't came off the trailer we jus got in late last Night ill try to get a video up here in a day or two
 

·
I am unique
Joined
·
22,621 Posts
Alright it still hasn't came off the trailer we jus got in late last Night ill try to get a video up here in a day or two
Also check for loose hardware in the bike at the motor mount points and broken or cracked frame..........
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Hey well I was gonna play around With it today. And went to start it up an it has compression and tries to turn over but it jus seems like the valves are floating or something all its doing is backfiring.. sooo where should I go from here...?
 

·
I am unique
Joined
·
22,621 Posts
Hey well I was gonna play around With it today. And went to start it up an it has compression and tries to turn over but it jus seems like the valves are floating or something all its doing is backfiring.. sooo where should I go from here...?
Rather vague description but I also suggest adjusting the valves as a start.............
 
1 - 8 of 8 Posts
Top