Raptor Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My boss's raptor had the clutch go out the other day, so I tore it down to replace it.
I followed the step by step on here in the stickies.
Soaked the clutch, put all the plates back in the same way they came out, aligned the lever shaft, and everything in the step by step.

The first time I put it all back together, I had a hard time selecting gears, but none of the gears worked.

So I took it all back apart, rechecked everything and put it back together..

Now if you pull the clutch lever, its real stiff.
The clutch will not disengage so if you ty starting it with it in gear and the clutch lever pulled in, it starts jumping and tries to take off.

I tried adjusting the cable on both ends and nothing made a difference.

One thing that I've noticed is that when tightening the bolts for the 5 springs down to 5.8 ft/lbs, the springs look and feel like they bottom out and possibly holding the pressure plate too tight.

Any help to get this thing going would be awesome. I'm so tired of pulling the clutch cover off over and over.

Thanks
 

·
I am unique
Joined
·
22,621 Posts
My boss's raptor had the clutch go out the other day, so I tore it down to replace it.
I followed the step by step on here in the stickies.
Soaked the clutch, put all the plates back in the same way they came out, aligned the lever shaft, and everything in the step by step.

The first time I put it all back together, I had a hard time selecting gears, but none of the gears worked.

So I took it all back apart, rechecked everything and put it back together..

Now if you pull the clutch lever, its real stiff.
The clutch will not disengage so if you ty starting it with it in gear and the clutch lever pulled in, it starts jumping and tries to take off.

I tried adjusting the cable on both ends and nothing made a difference.

One thing that I've noticed is that when tightening the bolts for the 5 springs down to 5.8 ft/lbs, the springs look and feel like they bottom out and possibly holding the pressure plate too tight.

Any help to get this thing going would be awesome. I'm so tired of pulling the clutch cover off over and over.

Thanks
Did you time the clutch components when assembing, there are timing marks on the hub and pressure plate...........
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yes I did.
Everything was done just how the write up on here and the FSM says to do it.

The only thing I thought was odd is the 5 pressure plate springs being fully compressed when I tightened the bolts for them. When I took the clutch apart, those bolts were barely hand tight and the springs were not fully compressed.

I have to be missing sumthing.
 

·
I am unique
Joined
·
22,621 Posts
Yes I did.
Everything was done just how the write up on here and the FSM says to do it.

The only thing I thought was odd is the 5 pressure plate springs being fully compressed when I tightened the bolts for them. When I took the clutch apart, those bolts were barely hand tight and the springs were not fully compressed.

I have to be missing sumthing.
Yes you are or you wouldn't be asking question here........:D
 

·
Master of the Electron
Joined
·
15,635 Posts
... Raptor clutches suck
Hmmm... the majority of ALL stock Raptor clutch assemblies work just fine.

If you want help, describe your timeline and issues... a broad brush condemnation of Raptors, here, won't get you very far.
 

·
Registered
Joined
·
495 Posts
Im with quad..... there pretty good imo...

In fact i just broke a basket n my trsil bike and it locked the motor up runnin 60 mph... im goin with a billet basket, gytr clutch n springs and running a lock up cover (Cover only) to make it easier to work on...

Just a thought but did u set the mark on the puller and the mark on the cover right?
 

·
Registered
Joined
·
3,459 Posts
Im with quad..... there pretty good imo...

In fact i just broke a basket n my trsil bike and it locked the motor up runnin 60 mph... im goin with a billet basket, gytr clutch n springs and running a lock up cover (Cover only) to make it easier to work on...

Just a thought but did u set the mark on the puller and the mark on the cover right?
were ya getting ur lockout??
 

·
Registered
Joined
·
495 Posts
One in my shop lol... i still got a few things layin around from my racing days lol
 

·
Registered
Joined
·
442 Posts
I am suffering a little again. THe clutch engages and works great but I noticed when I punch down on it the clutch slips some. It doesn't lay the full power down despite it revving like it does. Is this a symptom of new clutches or bad adjustment ? Those two little nuts that hook between that bracket off the motor are backed to the tip top right. I have been cruising around looking for info on it but nothing yet. I do have a lot of Raptor stuff btw. I have some Aeroflex fatty bars, A skids, stock a arms, the basket that holds the clutch plates, stainless steel screw set for carbs. I actually have like 3 sets. I bought stainless, carbine, and zinc not knowing which was best. I have tons extra
 
1 - 14 of 14 Posts
Top