Raptor Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
Like the title says. This has now happened two times. Usally right after startup within one min. I'll be on the gas and it will backfire which kills the engine. I'll restart it in which it catches instantly, but now it runs like it needs to be choked for about 10 min of idle...Any ideas?
 

·
Registered
Joined
·
182 Posts
Discussion Starter #3
Think it could really be fouling the plug already? Its not even completly through its second tank of gas!?!?
 

·
Premium Member
Joined
·
5,119 Posts
scott011422 said:
Like the title says. This has now happened two times. Usally right after startup within one min. I'll be on the gas and it will backfire which kills the engine. I'll restart it in which it catches instantly, but now it runs like it needs to be choked for about 10 min of idle...Any ideas?


Why are you on the gas after 1 Minute? It's still cold and sneezing back out of the carb, give it 5 mins or so to warm up and do not touch the throttle to start it or for the first few minutes of warm up or it will fuel foul plugs.
 

·
Registered
Joined
·
278 Posts
RaptorRandy27 said:
scott011422 said:
Like the title says. This has now happened two times. Usally right after startup within one min. I'll be on the gas and it will backfire which kills the engine. I'll restart it in which it catches instantly, but now it runs like it needs to be choked for about 10 min of idle...Any ideas?


Why are you on the gas after 1 Minute? It's still cold and sneezing back out of the carb, give it 5 mins or so to warm up and do not touch the throttle to start it or for the first few minutes of warm up or it will fuel foul plugs.
Carb?
 

·
Registered
Joined
·
22,016 Posts
mrtrick said:
RaptorRandy27 said:
scott011422 said:
Like the title says. This has now happened two times. Usally right after startup within one min. I'll be on the gas and it will backfire which kills the engine. I'll restart it in which it catches instantly, but now it runs like it needs to be choked for about 10 min of idle...Any ideas?


Why are you on the gas after 1 Minute? It's still cold and sneezing back out of the carb, give it 5 mins or so to warm up and do not touch the throttle to start it or for the first few minutes of warm up or it will fuel foul plugs.
Carb?
The carb was an option on some '07 models.

:brick:

~Brian
 

·
Registered
Joined
·
22,016 Posts
I ALMOST put "Just kidding" in the post but figured the :brick: explained that I was just kidding.

Oh well, no worries, I've done the same thing. Just look at it and laugh it off.

:lol:

~Brian
 

·
Registered
Joined
·
17,851 Posts
mrtrick said:
I was hoping so... but hey... I'm gullible I guess.

Me
:stupid:
I'd almost suggest to you just call brain a freakin bastard, but then.... you may end up being the "New RaptorBoy" And I wouldn't wish that upon anyone but raptorboy himself. :p
 

·
Registered
Joined
·
468 Posts
Let the bike idle after starting until it is warm. Our Rappy's need time to warm up. Do not punch the throttle to expedite the process. I always warm mine up around 5 min or so before riding.

Craig,
 

·
Premium Member
Joined
·
5,119 Posts
RaptorRandy27 said:
scott011422 said:
Like the title says. This has now happened two times. Usally right after startup within one min. I'll be on the gas and it will backfire which kills the engine. I'll restart it in which it catches instantly, but now it runs like it needs to be choked for about 10 min of idle...Any ideas?


Why are you on the gas after 1 Minute? It's still cold and sneezing back out of the carb, give it 5 mins or so to warm up and do not touch the throttle to start it or for the first few minutes of warm up or it will fuel foul plugs.

Ok I said carb instad of throttle body, I'm a little loopy on pain pills today but the rest is accurate.
 
1 - 13 of 13 Posts
Top