Raptor Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Charged the battery to full charge...hooked it up to the bike will usually start the bike once or twice...but then the battery is dead again. Tried to ride to charge the battery but still dead! The bike starts good if you jump or pull start it....just always a dead battery......(battery was bought new)
Thanks

p.s
have fan wired to toggle switch.
 

·
Premium Member
Joined
·
4,191 Posts
The '04-'06 models have an issue where the battery isn't going to charge unless you run the lights all the time. I can't remember if this is on all of them or just on some of them, but I know mine has this same issue. That, and I can't seem to keep a pair of bulbs from blowing out for more than an hour.
 

·
Master of the Electron
Joined
·
15,680 Posts
IT's yours, cdg... your regulator must have issues.
 

·
Registered
Joined
·
6,002 Posts
The '04-'06 models have an issue where the battery isn't going to charge unless you run the lights all the time. I can't remember if this is on all of them or just on some of them, but I know mine has this same issue. That, and I can't seem to keep a pair of bulbs from blowing out for more than an hour.
I know alot of the YFZ's will not charge, I have heard this many times. When people remove the headlights the issue comes around, don't they do some resistor mod?
 

·
Premium Member
Joined
·
4,191 Posts
IT's yours, cdg... your regulator must have issues.
QM, I would have thought it was just mine, but I'd hate to count how many people over on Central have the same issue with their bikes in that year range. I'm not saying I don't have a regulator issue, but I think it's just a common problem with these bikes, unless you do a replacement.

I know alot of the YFZ's will not charge, I have heard this many times. When people remove the headlights the issue comes around, don't they do some resistor mod?
I don't remember if it's a resistor mod or what it is, I looked at the time this thread was started (on Central), and couldn't find the threads, but there are a ton of them.

Ricky Stator makes a good stater replacement to cure that...
+1, if I keep the bike, I'm more than likely going this route.
 

·
Registered
Joined
·
26 Posts
Mine did the same. Battery would drain from the cranking. Bike would turn on once or twice but then be dead..switch over to a yuasa ytz-10s. Its a cbr battery with double the cca's. Its a lil bigger the the stock yfz but a lik trimming of the battery box and your problems solved..
 
1 - 7 of 7 Posts
Top