Raptor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
hey guys i recently bought a black chrome HMF exhaust for my 700R... i put in on and it runs great... everything is stock except for the pipe!... it doesent backfire or pops when i decelerate and runs just like when it had the stock exhaust on just alot louder:D... after couple hours of driving my tps went bad ... it wouldnt idle anymore and would sputter at low rpm's but runs great at WOT!... i was just wondering if maybe the pipe had anything to do with the TPS going bad???... and even if it runs good with no backfiring or popping and my plug isnt white either ... if i would need a fuel controller also ???...thx for your help !
 

·
Registered
Joined
·
242 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #3
thx !! i changed the tps earlier and it seems to work good again ! ... but even with it not running lean ... if i only want noise for now is it ok to run it without the fuel controller or will it damage something?
thx again!
 

·
Registered
Joined
·
54 Posts
Discussion Starter #4
ohhh and also the tps wasnt made the same as the one that was on !!... i hear they changed or recalled the 06-07 ones .... does this make sense ?... cuz it's working fine but im worried that it wont seal properly from the way it looks
 

·
Registered
Joined
·
448 Posts
I'd still get a fuel controller just to be safe. It may ride now but over time the piston will start to wear faster due to the leaner conditions from the pipe
 

·
Addicted To Raptor
Joined
·
255 Posts
+1 on the fuel controller ...... It just makes everything jive better!
 

·
Registered
Joined
·
54 Posts
Discussion Starter #8
thx for all your reply's guys !! ... i'll be getting a fuel controller in the next week or so :D... and about the new sensor ..does anyone know if it's suppose to be different from the old one??

thx again !:metal:
 
1 - 8 of 8 Posts
Top