Raptor Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
My son wanted to take it out this winter when I was gone to pull a sled, it was -5 F so he killed the battery. He then used my big charger which ruined the battery so I bought a new one. It still wouldn't start so I looked it over and found a fuse next to battery box burnt and I replaced it. It presently is sitting in my heated garage and still won't fire off. Is there another fuse or could he have burnt something else up on it? It has spark when I checked it. Does anybody know where to download a free manuel on the electrical part of it on the internet I could use?
Thanks in advance for everybodies feed back I am hoping to get.

Well I got it to finally start, it was a weak, not fouled plug. So I took it for a spin and it popped the EFI fuse (10AMP). I put another one in and turned the key on and the fuel pump turned on and popped the fuse again. So at this point I had to get it back home so I put a 15 amp in it, yes I know that’s not good to do but had to get it back home or push it, it did not pop that fuse so when I made it back I put another 10 Amp in and same thing, POP. Can anybody tell me what this could be caused from? Could there have been more damage from charging the battery wrong the first time?
 

·
Registered
Joined
·
27 Posts
Hey nelson, there are links on this site for free manuals.. they've been supper helpful to me! As far as your Rap.... go to the basics, you need spark, fuel and compression to start. You say you have spark.....With the fuse being blown, I'd take an ohm meter and check all of them. My guess is the fuse for the fuel injector circuit. But he might have fried some relays. Do you hear the fuel pump hum when you turn on the key? If not... there's a prob somewhere in your fuel circuit. Good Luck and keep us posted on your progress!
 
1 - 2 of 2 Posts
Top