Raptor Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey Folks,

My parents have a 2012 250 that they take out a few times a year to ride. Recently it randomly started to cut out/sputter at WOT and high RPM's. If you ride it a gear too high (lugging it a bit), it runs fine. It has more power chugging along than anywhere close to the rev-limiter. It is completely fine bouncing off the actual rev-limiter in neutral. The problem only appears during high load AND high rpm.

What I've done so far-

Ultra-Sonic cleaned Carbs, all new jets/o-rings
A bunch of Main Jets, from 130-150 in steps of 2.5 (Same Condition)
Double and triple Checked all the intake clamps
Checked for air leaks with engine running with carb cleaner (nada)
Brand new Air Filter, with a very modest amount of oil
New Spark plug
Checked Valves
Checked Timing
Checked Fuel flow from petcock
Checked gas cap vent
Checked Float height
Checked the Primary and Secondary Coil windings per manual
Checked Pulse Generator
Checked Battery

Spent the whole day with this damn thing, my best guess now is CDI or stator. Im convinced it's something to do with spark and not jetting. If it was the Main Jet, it would run like garbage at full throttle period. It's had the same jetting since day 1 at all sorts of different elevations and temperatures and it's never been a problem. Was hoping that somebody on here has dealt with something similar, CDI's aren't cheap nor are stators. Thanks!
 

·
Registered
Joined
·
3 Posts
Hey Folks,

My parents have a 2012 250 that they take out a few times a year to ride. Recently it randomly started to cut out/sputter at WOT and high RPM's. If you ride it a gear too high (lugging it a bit), it runs fine. It has more power chugging along than anywhere close to the rev-limiter. It is completely fine bouncing off the actual rev-limiter in neutral. The problem only appears during high load AND high rpm.

What I've done so far-

Ultra-Sonic cleaned Carbs, all new jets/o-rings
A bunch of Main Jets, from 130-150 in steps of 2.5 (Same Condition)
Double and triple Checked all the intake clamps
Checked for air leaks with engine running with carb cleaner (nada)
Brand new Air Filter, with a very modest amount of oil
New Spark plug
Checked Valves
Checked Timing
Checked Fuel flow from petcock
Checked gas cap vent
Checked Float height
Checked the Primary and Secondary Coil windings per manual
Checked Pulse Generator
Checked Battery

Spent the whole day with this damn thing, my best guess now is CDI or stator. Im convinced it's something to do with spark and not jetting. If it was the Main Jet, it would run like garbage at full throttle period. It's had the same jetting since day 1 at all sorts of different elevations and temperatures and it's never been a problem. Was hoping that somebody on here has dealt with something similar, CDI's aren't cheap nor are stators. Thanks!

For whatever reason, I couldn't post using my Facebook login any more, so I had to register. I felt compelled to post what the resolution was for future reference for anyone that has this very frustrating issue.

The float height was off by about .5mm, which is about .020" (very little), but I spent a good 20 minutes making sure it's exactly 13mm like the book says. Again I put the biggest main jet I had on hand and while the problem wasn't gone completely, the quad pulled noticeably harder and got closer to the rev-limiter than before, at that point I was 100% sure it just needed a really rich main.

So, yesterday I went to the local dealer and asked for the biggest main jet they had in stock, which happened to be a 157.5. I put it in and it ran really good. Still a small hiccup at full throttle and high RPM, but the quad will now pull thru all the gears and hit the actual rev-limiter. A plug chop test on a new spark plug confirms that it's still lean, I suspect that a 160 or a 162.5 main jet will be the ticket.

As far as why the quad all of the sudden needed much richer jetting, I'm still scratching my head. As stated before, it's had the airbox lid off and no spark arrestor since day 1 with the stock jetting and no issues.
 
1 - 2 of 2 Posts
Top