Raptor Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

I have recently purchased a 2001 Raptor 660R that was sputtering a little bit at high RPMs. I got it pretty cheap and figured it would give me something to do during quarantine. I have read a lot on here about issues with the parking break and reverse wiring, but their is no parking break on this quad, and I am unsure what to look for on the reverse wiring. There are no splits in the wiring. Today I cleaned the carb and set the air to fuel back to factory spec, 2 and 3 turns out, on the inside of the carb. I have a K&N air filter with holes drilled into the top air box lid and aftermarket slip on, and I am coming to the realization that has something to do with it running lean, I covered the drilled holes and it didn't seem to change anything. What are your thoughts about this? Where the choke threads into the carb has broke and now my starter wont engage, it turns but wont grab unless I wiggle the choke cable, and the start wont grab long enough to start it.

Overall, I need advice on what to do next. Can I remove the choke cable out of the carb for now, or will that spring an air leak making my lean running engine worse? I have the feeling this has something to do with it not wanting to start, as the engine died when I engaged the choke. Next, because of it running lean with my aftermarket slip on and air filter, am I better off getting a stock air filter, or going with different jets? What size jets should I running with my circumstance?
 
1 - 1 of 1 Posts
Top