Raptor Forum banner

1 - 20 of 47 Posts

·
Dirty Lil Bastard
Joined
·
602 Posts
Discussion Starter #1
A friend and I are trying to resurrect a like new Raptor that's been sitting in a garage for 4 years. I bought a carb rebuild kit for it we cleaned the carb really really good. Set it all to factory settings and it's running lean.

Thoughts?
 

·
Super Moderator
Joined
·
17,058 Posts
Bike is bone stock? Airbox lid and snorkel intact? No leaks in the intake boots?
 

·
Dirty Lil Bastard
Joined
·
602 Posts
Discussion Starter #3
Not that we've found. Baffle is even still in...this thing looks brand new still. We're double checking that again tonight but all the rubber and plastic appears new.
 

·
I am unique
Joined
·
22,621 Posts
A friend and I are trying to resurrect a like new Raptor that's been sitting in a garage for 4 years. I bought a carb rebuild kit for it we cleaned the carb really really good. Set it all to factory settings and it's running lean.

Thoughts?
Why do you think it is running lean..........
 

·
Master of the Electron
Joined
·
15,074 Posts
Did you actually rod out the pilot jets so you could see nice, round shafts of light coming through each? If not, I suggest you do them again.

Where in throttle position is it acting lean?
 

·
Dirty Lil Bastard
Joined
·
602 Posts
Discussion Starter #6
That has been done QM. This a video of it running. First part is with the choke on then the next part is with the choke off.

 

·
Dirty Lil Bastard
Joined
·
602 Posts
Discussion Starter #7
The carb has all brand new jets, needles, and float needle seats.
 

·
Registered
Joined
·
267 Posts
I had that same issue with my girlfriends raptor 660. We bought it, bone stock. IT ran fine but the carbs leaked so i rebuilt them with stock needles, jets, floats and all that stuff. It ran like royal crap. I put some 25 pilots in there and raised the needles one clip and it runs like its brand new! IDK why it did that and i will never know why but it works!
 

·
I am unique
Joined
·
22,621 Posts
It isnt idling fast enough..............
 

·
Dirty Lil Bastard
Joined
·
602 Posts
Discussion Starter #10
What does the idle have to do with it?
 

·
Master of the Electron
Joined
·
15,074 Posts
It is idling too slow... get the idle speed up and see if you still have issues.

You haven't answered our questions... WHY do you think it's lean and under what conditions?
 

·
I am unique
Joined
·
22,621 Posts
It is idling too slow... get the idle speed up and see if you still have issues.

You haven't answered our questions... WHY do you think it's lean and under what conditions?
And I also noticed that the engine backfires when you blip the throttle, but it is cold..........
 

·
Dirty Lil Bastard
Joined
·
602 Posts
Discussion Starter #14
We idled it up. We drove it and it still backfires. You press the throttle and it feels like it runs out of fuel. When you shut the choke off it barely runs. We've moved the needles and it's the same.
 

·
I am unique
Joined
·
22,621 Posts
We idled it up. We drove it and it still backfires. You press the throttle and it feels like it runs out of fuel. When you shut the choke off it barely runs. We've moved the needles and it's the same.
Then clean the carbs, dismantle and clean all the jets and passages using a rod or small wire to remove any varnish or gum............
 

·
Dirty Lil Bastard
Joined
·
602 Posts
Discussion Starter #16
carbs were stripped completely and the bodies soaked in gunk for a week. Then they were scrubbed inside and out before rebuilding with all new jets and orings. As far as I can tell there are no cracks in the boots or intake.
 

·
Master of the Electron
Joined
·
15,074 Posts
This is why we asked WHY do you think it's lean - what you are describing so far does not necessarily indicate lean running... more detail would help a lot.

Are you familiar with the two RPM limiters (parking brake and reverse) that can make the bike spit and sputter just above idle if they are malfunctioning?
 

·
I am unique
Joined
·
22,621 Posts
We idled it up. We drove it and it still backfires. You press the throttle and it feels like it runs out of fuel. When you shut the choke off it barely runs. We've moved the needles and it's the same.
Which needles and which way did you move them...........
 

·
Registered
Joined
·
267 Posts
By any chance did you use the Shindy brand rebuild kit? I had a problem with their fuel screws.

1. Use the Original fuel screws
2. Use the Original needles
3. Lower the clips on the needles one notch and make sure your plastic shims are below the needles and not above them. Meaning, put the plastic shim in the hole before the needle goes in.
4. Make sure that the 140 jet is on the left and the 145 is on the right (sitting on the bike left is left and right is right)

Like i said before, i had this EXACT same issue with my girlfriends raptor when i rebuilt it back to stock specs. I even got the floats set to the 3mm line. As soon as i hit the gas it would fall on its face. I took this carb apart 12 times to get it right. If you have an issue with the fuel bowl gasket stretching on you here is a tip: Use a dab of grease in the grooves to hold it in place while you work it in. That helps a TON!
 
1 - 20 of 47 Posts
Top