Raptor Forum banner

1 - 20 of 20 Posts

·
Super Moderator
Joined
·
17,058 Posts
Perhaps you could post it here, and then actually explain what the problem is.
 

·
Master of the Electron
Joined
·
15,074 Posts
Welcome to the forum.

We can't read your mind. If you're not willing to, at least, post your issues here, why should we be willing to spend time to help?

"really shitty" doesn't give us anything to work with - explain symptoms with DETAIL.
 

·
Master of the Electron
Joined
·
15,074 Posts
I DID open the link... where do you think I got the "really shitty" quote?

Give some details if you want some help.
 

·
Super Moderator
Joined
·
17,058 Posts
Just open the link I am doing this from a phone so its a pain to retype
Phones have copy and paste functions, which is how you probably posted the link here. You can try that.

But your content in the other link does not explain any specific problem, just a general complaint that it seems low on power. What makes you think it's low on power? How does the machine react when you hit the throttle? How about when you rev out in gear under load? What jetting does it have now? Does it run rough, or just slow? Has it sat in storage for a period of time? Have the carbs been cleaned since?

You need to give us some more information, and make an effort if you expect anyone else to do the same.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Sorry guys didn't realize. K guys not trying to be a dick but I just got an 01 660 the motor trans and clutch setup is all new. This thing to me is really shitty feels so under powered. I remeber when I had a 88 trx 250r and my friend had an 01 660 with some pipe kit and that thing felt pretty powerful. My 01 also has a yosh full pipe. My current bike is an 06 trx450r with hrc full kit airbox mod and rev limiter mode. Now I haven't rode the 450r in about 6 months.
 

·
Master of the Electron
Joined
·
15,074 Posts
Okay, so, as MD so eloquently put - how about some specifics? Under powered tells us nothing. We need detailed explanation of symptoms to help you get to the core problems.
 

·
I am unique
Joined
·
22,621 Posts
Sorry guys didn't realize. K guys not trying to be a dick but I just got an 01 660 the motor trans and clutch setup is all new. This thing to me is really shitty feels so under powered. I remeber when I had a 88 trx 250r and my friend had an 01 660 with some pipe kit and that thing felt pretty powerful. My 01 also has a yosh full pipe. My current bike is an 06 trx450r with hrc full kit airbox mod and rev limiter mode. Now I haven't rode the 450r in about 6 months.
So what do you want to know.............
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Their just doesn't really feel torque. From what I had rembered from my friends was I couldn't keep the front wheels down felt torque.
 

·
I am unique
Joined
·
22,621 Posts
Their just doesn't really feel torque. From what I had rembered from my friends was I couldn't keep the front wheels down felt torque.
What gearing are you using.............
 

·
Master of the Electron
Joined
·
15,074 Posts
Last attempt to get some detail...

Does it start easily?

Does it idle well?

Does it transition from idle to on throttle without stumbling or hesitating?

Does it run all the way up to wide open throttle steadily or have bumps/spits or sputters?

Etc., etc., etc.

Come on, we're already on the second page and all we know is that it doesn't have the power you expect. You have to give some detail or you're not going to get any feedback of value. At present, response from us of "replace the entire engine" would be just as relevant as "replace the spark plug"... with the info you've provided so far. There is no one common failure that makes the bike seem low powered. There ARE, however, a lot of small symptoms which, when added up, can cause the loss in power and help point to the problem. This is the detail we're looking for.

Raptors, in good working order, will pull the front wheels up easily in 1st, 2nd and 3rd... so you obviously have a problem... but without further detail on the symptoms, so we can help you, you're going to end up taking it to a shop.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
No run problems at all. I think it was stock gearing and my friends that I rode I am not sure at all of what that was I just know bike starts right up runs really good just doesn't have any type of balls to it. Lie I said the motor trans and did are all brand new.
 

·
Master of the Electron
Joined
·
15,074 Posts
"all brand new"? Who did the work and how are you certain that it was done properly? For example, how do you know the cam timing isn't off by one tooth? (this could certainly cause some issues like you are seeng). Have you even verfied that the engine has good compression?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #16
Yes good compression and my local dealer did the work. They are known to be good and have never screwed up a job I have given them
 

·
Master of the Electron
Joined
·
15,074 Posts
Well, if this entire job was done by them and the bike is lacking in power (which it certainly is if you can't even get the front wheels up), then they DID do something wrong, perhaps very simple, but wrong still... My first suggestion would be to get them to resolve the issue, since it is their responsibility; unless you have had more contribution to the effort than you have admitted to as of yet.
 

·
Master of the Electron
Joined
·
15,074 Posts
God I love going in circles... good luck to you.
 
1 - 20 of 20 Posts
Top