Raptor Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Ok this is my very first post, My raptor that I just bought from a guy like 2 months ago had been starting fine, one day I go to the garage to start it and all it does is pop and back fire, eventually tore the carbs down and cleaned them, nothing real bad, now that I put it back together it turns over but wont stay running, I actually stayed on the gas and it stayed running, as soon as I got off the gas it kills, sometime it will stay on, sometimes it wont, any suggestions?
 

·
Registered
Joined
·
819 Posts
Welcome to the forum! Is this your first four wheel or raptor 660? Make sure that your carbs are fully seated in the boots. A big backfire can cause them to pop off and then your bike wont run or it will run very poorly
 

·
Registered
Joined
·
18 Posts
I had an issue like this, my raptor wouldnt stay on and wasnt getting full power. The wire that is connected underneath the front sprocket was my problem. All i did was tighten it up and it ran fine. Just a possibility takes 10 seconds to check.
 

·
I am unique
Joined
·
22,621 Posts
Ok this is my very first post, My raptor that I just bought from a guy like 2 months ago had been starting fine, one day I go to the garage to start it and all it does is pop and back fire, eventually tore the carbs down and cleaned them, nothing real bad, now that I put it back together it turns over but wont stay running, I actually stayed on the gas and it stayed running, as soon as I got off the gas it kills, sometime it will stay on, sometimes it wont, any suggestions?
Possible parkbrake rev limiter is coming on, check the switches by the park brake handle or just disconnect the wires from the main harness and seal the plugin............ green and yellow wire and a black wire
 

·
Master of the Electron
Joined
·
15,622 Posts
Read "Most Common Problems with the Raptor 660", a sticky at top of the General 660 Discussion section - pay attention to the RPM limiter section, as Willy has suggested. Does this sound like your problem?
 
1 - 7 of 7 Posts
Top