Raptor Forum banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
812 Posts
Discussion Starter · #1 ·
Went to go for a ride today and the raptor won't start, all the lights come on on the dash but it just clicks when I hit the start button.

There is a box that the positive wire from the battery runs too and it is what is making the noise, I can feel it vibrate when I try to start it. Is that the starter goin bad?
 

·
Registered
Joined
·
2,674 Posts
the solenoid is bad. (the little box that the two wires are hooked too that is buzzing) but also put a charger on it first and make sure the battery is hot enough. you can jump those two post across each other with a screwdriver and if it cranks its the solenoid. also make sure the wires are tight
 

·
Premium Member
Joined
·
812 Posts
Discussion Starter · #3 ·
Cool I will do that and check. How much is a new solenoid?
 

·
Registered
Joined
·
95 Posts
Cool I will do that and check. How much is a new solenoid?

I had almost the exact same issue with my Rappy. It ended up being a bad battery. Take your battery down to your local Advanced Auto Parts and ask them to test the "cranking volts". Hope that helps I know it drove me crazy tryin to figure it out cause with a multimeter my battery tested good. Apparently there is a differance in normal volts and cranking volts... gotta say they never tought me that in High School Auto Shop! Good Luck!
 

·
Registered
Joined
·
1,045 Posts
My brotha, I'm not sure if Odyssey makes a battery for the Raptor yet, but when I needed a new battery they didn't. I got a YFZ450 Odyssey battery instead and applied that to my Raptor.

That was in 2007. I still have the same battery, and I've only had to charge it once..
 

·
Premium Member
Joined
·
812 Posts
Discussion Starter · #6 ·
Took the battery to get checked and they said its still good and to put it on a trickle charge and it should be good. So we will see what happens in an hour. If it still don't work should I replace the battery or get a new solenoid?
 

·
Registered
Joined
·
1,045 Posts
Try to jump it before you replace the battery, if that doesn't work than jump the solenoid as described above. If it starts, you know the culprit.
 

·
Registered
Joined
·
95 Posts
Try to jump it before you replace the battery, if that doesn't work than jump the solenoid as described above. If it starts, you know the culprit.
I agree, I jumped my battery when the same happened and it fired right up. However when the charge was removed the machine would eventally stall out. If the jump start works, I would suggest goin to a new shop and get a second opion on if the battery is acually pushing enough "Cranking" amps. If not could be a number of things in the circuit from the starter switch to the acual starter. If you have a OEM manuel that will help your troubleshooting out a ton. I beleive you can download one from this site.
 

·
Premium Member
Joined
·
812 Posts
Discussion Starter · #9 ·
I tried bridging it and it still made the same sound. It's on the charger now, hopefully it works.

I had to pull start it when I was out riding, it ran fine but when I turned it off it wouldn't restart.
 

·
Registered
Joined
·
2,406 Posts
Cool I will do that and check. How much is a new solenoid?
I just went through this with my bike, Do yourself a big favore & get a OEM solinoid..They are between $$40-70 depending on ware ya get it. The cheep $20 one's on Ebay suck bad....
Good luck...
 

·
Registered
Joined
·
615 Posts
Mine did the same thing last month, it ended up being the battery. Just test everything before you go buying any parts otherwise you could end up spending alot more money than you need to.
 

·
Registered
Joined
·
2,406 Posts
Mine did the same thing last month, it ended up being the battery. Just test everything before you go buying any parts otherwise you could end up spending alot more money than you need to.
+1. You can test your solinoid by crossing the + & - posts on the solinoid..But like mentiond make sure your battery is fully charged..
Good luck.
 

·
Premium Member
Joined
·
812 Posts
Discussion Starter · #13 ·
All better, hooked it up to the trickle charge and its back running like a champ. Guess its time I get it a new battery. Thanks for all the great help guys.
 
1 - 13 of 13 Posts
Top