Raptor Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I just installled the Alba Racing Exaust kit (full pipe, Velocity Intake, Boss Noss gen III EFI, air box cover off) and it sounds great. When I test drove it, I did not feel a major difference over stock. I set the EFI controller to the following recommended settings:
Green Light(pilot/cruise fuel) to 3, Yellow Light(needle slide/accelerator pump) to 6, Red Light(main jet/add fuel) to 7-8,
Yellow and Blue light(main jet/pull fuel) to 5 (trail setting), and Red and Blue Light(adjustable RPM setting) to 4 (trail setting). The bike runs fine and doesn't smoke or back fire but when I pulled the new plug it was black and sooty. I know this means that the bike is running rich but I'm not sure what settings(lights) to adjust to lean the bike out a bit. Can anyone give me some advice on what to adjust or does anyone have this kit and what settings are you using.
 

·
Registered
Joined
·
135 Posts
i have the same kit. i just left all the settings at 5 which is the optimal setting for almost all conditions. cause i tuned mine and my plug did the same thing so i called alba and the pricks couldnt even tell me what i did wrong. so i swithched back to all 5 position and no problems yet.
 

·
Registered
Joined
·
100 Posts
I have the same kit. send me a message maybe we can figure this out
 

·
Registered
Joined
·
76 Posts
If you talk to Matt Fasig at Alba he'll explain everything you need to know about the efi. The best thing to do is leave it at the pre programmed settings, if you want the default settings back just unplug the efi and it will go back to those default settings. Unless you have a dyno then there's really no point in changing these settings around, you could be losing performance. The Alba kit has done great for me so far I have not lost to another four stroke yet, not even to the guys that talk about there duals and pcIII's all the time.
 

·
Registered
Joined
·
100 Posts
Xlr8hers said:
so far I have not lost to another four stroke yet, not even to the guys that talk about there duals and pcIII's all the time.
Yea i know a few :lol:
 

·
Registered
Joined
·
135 Posts
ya if you leave it as it comes (preprogrammed) than those settings are all in 5 position
 

·
Registered
Joined
·
187 Posts
All i adjusted on mine was the Idle, turned it down a bit and yes the plug is sutty but id rather be rich than lean. ANyoen dynoed this kit?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #12 ·
Again I would like to thank everyone for the help. I set all the settings at 5 and the quad runs great. I took it for a ride and I can feel a major difference over stock. I pulled the plug and it looked a lot better than before. The bike still runs a little bit rich but rich is better than lean. I am waiting for my new wheels and tires to arrive (razzor 2's on ITP C-series black) from RM. They should be here by the end of April (back ordered) and then I will change my front sprocket to a 15t.
 
1 - 12 of 12 Posts
Top