Raptor Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, im a newb. and i have looked and didnt find my exact issue but im sure i will get bashed cause i doubt im the only one with my issue . Ok i have a 03 660, all stock . I started my bike the other day and it did start and run for about 20 seconds and as i was turning off my choke it died. Now it just turns over and is pushing gas out into the air box. I do have spark , and carbs have been cleaned. It acts like my timing chain may have jumped. I noticed on my left left carb gas is getting pushed back into filter box. On the left intake boot between the carb and head there is a port, so i went to shoot some intake cleaner threw the port to see if would try and start; and its pushing air out of the cylinder back to the carb. Which is why im getting gas in air box. Wondering if anyone can help me down the right path . Any help would be appriciated.
 

·
I am unique
Joined
·
22,621 Posts
Hi, im a newb. and i have looked and didnt find my exact issue but im sure i will get bashed cause i doubt im the only one with my issue . Ok i have a 03 660, all stock . I started my bike the other day and it did start and run for about 20 seconds and as i was turning off my choke it died. Now it just turns over and is pushing gas out into the air box. I do have spark , and carbs have been cleaned. It acts like my timing chain may have jumped. I noticed on my left left carb gas is getting pushed back into filter box. On the left intake boot between the carb and head there is a port, so i went to shoot some intake cleaner threw the port to see if would try and start; and its pushing air out of the cylinder back to the carb. Which is why im getting gas in air box. Wondering if anyone can help me down the right path . Any help would be appriciated.
Typical of dirty carbs, clean them properly and do a compression test............
 
1 - 2 of 2 Posts
Top