Raptor Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I bought a 03 660 not running. I cleaned the carbs and jets. Got it started and running. After warming up thoroghly I remove choke and it will barely idle. Riding is ok as long as you keep the revs up. It backfires from the exhaust constantly. I have researched some and dont understand what the screw turns are or what to turn. Not sure if this will fix my problem either. Ayone have any ideas.
No airbox lid and foam filter
Stock exhaust
Not sure if any otherchanges or mods have been done
 

·
Registered
Joined
·
18 Posts
Try downloading the manual (sse sticky's at the top of the page) and check the sticky's for carburettor set up tips.

I cannot recall where, but I did find the recommended turns for the air screw in the sticky's recently when I was looking
 

·
Premium Member
Joined
·
956 Posts

·
I am unique
Joined
·
22,621 Posts
I bought a 03 660 not running. I cleaned the carbs and jets. Got it started and running. After warming up thoroghly I remove choke and it will barely idle. Riding is ok as long as you keep the revs up. It backfires from the exhaust constantly. I have researched some and dont understand what the screw turns are or what to turn. Not sure if this will fix my problem either. Ayone have any ideas.
No airbox lid and foam filter
Stock exhaust
Not sure if any otherchanges or mods have been done
I suggest you dismantle the carbs again and reclean all the jets and pay attention to the pilot jets, these are the main source of fuel at idle, are very small and prone to being plugged when the bike has sit for a while. The fact that you dont have an air box lid will not affect your idle jetting much..........
 
1 - 6 of 6 Posts
Top