Raptor Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
Finaly got to go out and play with my new set up. My god what a diferance the pipes and intake made. :thumbsup: :thumbsup: I weigh 235 lbs and it was all I could do to keep the front end down in first and second gear. Did a lot of climbing and flat out runs and was very impressed by the diferance in peffomance going to go to pismo in a few weeks and try it out there.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #4 ·
I have a trinity intake with K&N filter seems to be a good combination with the Barkers
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #5 ·
techquadshop said:
Glad you like them! Let me know when your ready for the high-comp piston. ;)
think I'll start working on the suspention now gotta save some money up tho spent my alowance on the pipes and PCIII
 

·
Registered
Joined
·
902 Posts
Just put on my Barker's, Trinity Air Intake and PCIII this weekend.

Only rode it down the street and back so, no way to tell on power but, it lifted the front end without a problem.

Can't wait to get her in the sand.

What fuel map are you using? Would like to get another so if it doesn't run well I can download it on to the PCIII easily.

Dune trip isn't for a few weeks yet.

Steering stabilizer should show next week so, I'll have more work to do next weekend.

Got the paddle tires on her also.

She's ready to go!!!
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #7 ·
OH one little issue I ran into with the PCIII, just a heads up for those who have it. I took it for a quick run when we first unloaded where we were riding and while I was putting my boots on I let my little brother take it for a spin, he got about 300 yards from me and the bike died. :mad: :mad: we towed it back to the truck and I looked at it it would crank but not fire I looked for all the usuall problems no luck.I pulled all the plastics off and lifted the gas tank and saw that the plug from the PCIII to the injector had almost came off. I know I pushed them all in solid when I installed it. so I pushed it back in and fired the bake up. (fired on first crank thank god) before I put every thing back together I checked all the conectors and the one I had just put back in was loose again :mad: I pushed it harder and heard it click rechecked all the conectors again and pushed extra hard and the rest of them clicked so when installing your PCIII push the conectors hard to seat them.
 

·
Registered
Joined
·
1,132 Posts
I'm still waiting on my pipes :(, got everything else. Where'd you get the stabilizer? I need one for me and the wifes quad.
 

·
Registered
Joined
·
241 Posts
Good to hear Snowman Steve at the Tech Quad Shop should just about have all my go fast bits , if only i could stop adding things to my list and charging my card before it gets to leave lol . The way im going ill own a share in the shop just kidding Steve Excellent Prices and the Service to match what more could you want ! :thumbsup:
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top