Raptor Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 06 raptor 350 began smoking at the battery which is new and charged new CD I box new relay and starter freshly rebuilt bike test ride was ok but lost all power on the ride back help whats wrong
 

·
Super Moderator
Joined
·
8,347 Posts
Confirm all ground wires are tight.

Welcome to the forum.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
The ground at relay was loose but will check the others tomorrow and possibly replace the one going to the starter and thank I had to get some help i figured all the hard stuff was behind me with the rebuild but will need the help with the wires I will update tomorrow with the result
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,690 Posts
Remove your battery cable to relay, relay cable to starter, and ground cable. Inspect all crimp connection for white or green corrosion. If so replace.
Wire brush or sand all connectors shiny clean, add a "light" coat of dielectric, (Vaseline works.).
Tighten all connections securely.

Check for a blown fuse.

Be sure to trickle/float charge your new battery for a few days. It should be around 13.5 volts.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Update it was the starter I took the old one off bike and spent it with my hand and could hear the inside all torn up so I put the other one on there i had and the end it was fine and went to turning over but got to figure what made it go bad both starters are new.
 

·
Registered
Joined
·
1,743 Posts
There may or may not be an issue with the engine electricals cooking the new starters.
But, it is not uncommon to get a new starter that is bad, especially china knock-offs.
 
1 - 7 of 7 Posts
Top