Raptor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
ok so i got the raptor to turn over, engine is not seized, and no more engine codes. but my decompression pin assembly gets stuck and it is sluggish to turn over. also it sounds like it wants to start but it just pops and every now and then a flame will come out the exhaust. could it possibly be my valves or timing? the cam chain also seems loose, it has a custom extended cam chain tensioner made from kenz. i have a custom made cam from kenz, and a 52mm throttle body with a RC 650 injector. help me please
 

·
Registered
Joined
·
167 Posts
If the cam chain is loose the cam could have slipped a tooth causing higher cylinder pressure when cranking on it.
 

·
Registered
Joined
·
217 Posts
Discussion Starter #3
yea i ment to check the timing but i got distracted. i forgot to mention that the sluggishness gets worse when i open the throttle. also it pops more when i open the throttle as well, but that makes sense
 

·
Registered
Joined
·
217 Posts
Discussion Starter #4
so i checked the timing and yea it was off by a tooth. when i pulled the cam shaft tensioner off the custom made extension chewed all up in the chain guide, so i put it back together with the proper timing and it jumped 2 teeth this time. so im going to put all new cam chain, guide, and a manual tensioner and hopefully this will fix the problem.
 

·
Registered
Joined
·
167 Posts
I Would use the stock tensioner it does the job as it should when everything is within proper spec. A manual tensioner you could put too much pressure on the chain and take out cam bearings or possibly more damage
 
1 - 5 of 5 Posts
Top