Raptor Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter · #1 ·
my 350 makes a little chhhickkkk noise when i am shifing hard. the clutch works fine and i am using it when i shift. This just started recently. engine oil level is fine. sort of makes the noise when i let off the gas when its at the peak of rmp too-- any ideas?

stupid question- the screw thing (that opens to the engine) opposite the oil check stick. What is that for? tried looking in and its like a piece of glass. i thought the cluch uses the engine oil but i could be wrong.
 

·
Premium Member
Joined
·
354 Posts
It does, what your looking at it the flywheel through the hole. Thats how you set tdc
 

·
Registered
Joined
·
49 Posts
Do you mean crunching gears as in when you miss a gear in a car and it makes that crushing sound be more specific I don't think anyone gets your problem. There's heaps of ppl here that would've solved your problem in the first 10 mins of you posting if you gave a good clear discription of what's happening to your poor rappy
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #7 ·
Ok. A bit of a grinding noise but it only last a second. Kind of like when you miss a gear on a car but faster pased. It happened as soon as I push down to shift not when I press the clutch. Just started recently and def is not normal. Recently changed the oil but used the correct viscosity.
 

·
Registered
Joined
·
49 Posts
Lol owwwwk just try adjusting your clutch from the lever and you'll be good..I'm trying to put that sound to words i can't....wonder how the comic book ppl do it?
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #9 ·
Its a click with allot of h's.. lol... I tried messing with the cluch cable and still makes it
 

·
Premium Member
Joined
·
354 Posts
Is your reverse lever fully engaged forward? You may have to adjust that
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #11 ·
Still happening. My reverse lever is fine. Tried adjusting the clutch cable. Nothing... it seems to not do it when I don't use the clutch. Starts when the engine gets hot
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #12 ·
You think this is an issue with my Tranny or is there another adjustment i am missing. i am going to try to adjust the shift lever.. possibly it is to far up or something.
 
1 - 14 of 14 Posts
Top