Raptor Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
Went out to sand mountain today and rode all day with my raptor. Put in a new clutch kit about 10-15 hrs ago and today all of a sudden, went to let out the clutch and no power to the rear wheels. You can hear the gears engage but when you let out the clutch it tries to go, but doesn't. Almost like the front brakes are on, but they are not. Could my clutch have gave way already?
 

·
Registered
Joined
·
348 Posts
If it is not making funky noises then I would think its slipping for some reason. Check your bolts/springs and make sure you didnt lose any fingers off the clutch basket. Also possible that now your clutch is adjusted to tight and you need slack in cable. Did this happen all of a sudden or gradually till it just wouldnt move anymore?
 

·
Registered
Joined
·
123 Posts
Discussion Starter #3
Happened all of a sudden. Went out behind the mountain, about a good 1/2 hour into the ride it just stopped working. And this was after a good 3 hours of hard riding.
 

·
Registered
Joined
·
330 Posts
Did you oil the clutch plates before you installed them? Probably a combination of that and major overheating of the clutch....Not sure but thats what it sounds like, you just burned your clutch up, or your clutch springs/ basket malfunctioned.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #6
Took it apart today. Clutches are wasted. Looks like I better put in some heavy duty one's this time around and see if they last. Any suggestions as far as clutch brands?
 

·
Registered
Joined
·
348 Posts
I dont know. I personally have yet to replace one. I know Rocky Mountain has Tusk and EBC brand clutch kits and are reasonably priced, but dont know how good they are :thumbsup:
 

·
Registered
Joined
·
123 Posts
Discussion Starter #9
Went with the EBC heavy duty kit, lets see how long it lasts.
 
1 - 9 of 9 Posts
Top