Raptor Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter #1
On a cold start the engine is somewhat noisy, not much noisier than other 700's ive heard but a good amount. When I pull in the clutch the noise doesn't necessarily get louder but the pitch changes for a moment. After the engine is fully warm it purs. I know the noise is coming from the clutch because I used a mechanics stethoscope. No slippage, no problems with the clutch otherwise. Given its an 06' and never been apart, should I still pull the cover and investigate? Maybe throw in a new clutch with the full fiber mod? I'm just wondering if I am catching something early? I don't remember it making this noise with the rotella I was running (just switched back to Mobil 1 4t because it was on sale). Any opinions?
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,043 Posts
It's obvious to me, you need to change back to Rotella, lol. If a lawnmower spark plug was on sale would you use it in your Raptor?

Seriously though, there is a small bearing for the pressure plate that drains oil when off, then takes a while for oil to splash on it after starting. If it sits for a week it's dryer then over night. If you take it apart for the bearing, might as well as replace the clutch with a kit. My suggestion is to stay away from Tusk and go with Driveline Performance. And get the reusable gasket from Cuervo.
 

·
Registered
Joined
·
342 Posts
Discussion Starter #3
Thanks Dez. Going to start it up and listen again after work. Might just send it for now!!
 
1 - 3 of 3 Posts
Top