Raptor Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Ok heres my issue. For the past year my Raptor has taken a spell..what happens is Ill start it up and start to ride it and all of the sudden ill give it gas and it acts like its is being limited in ever gear after it its a certain rpm. Well no it has all but stuck in that posistion meaning that I can start it and it will idel just like it always has but when ever enought throttle is applied it acts as if it will only hit a certain rpm and it chugs like its being choked. :mad:I can ride it in every gear but once each gear hits a certain rpm/speed around 5-8 mph it does it. So my question is what the hell could it be? I have hear a sensor some say the carbs but I would like a more definitive answer ...any Ideas? Thanks everyone. :thumbsup:
 

·
Registered
Joined
·
1,726 Posts
^ What he said.
Not complicated, actually rather common.
Parking brake or reverse, Most likely the p-brake, check the switches on the clutch perch parking brake assembly.

The reverse will blink the reverse light it the connection is bad. That connection is by the front sprocket, may need cleaning.
 

·
Registered
Joined
·
204 Posts
If none of those work check into your intake valves. They will also do this. It's happened to me b4 twice.
 

·
Registered
Joined
·
38 Posts
^ what they said... also if your quad has been sitting for a while you may have condensation in your gas. empty the tank, clean the carbs and get new gas.
 

·
Registered
Joined
·
34 Posts
I don't know if the same thing was happening to me but, my parking brake on the clutch lever was on, and it was was popping and wouldn't move very fast. I even burnt up my relay restarting it over and over again. Let me know if I am not being clear enough, but it sounds like the same issue. :thumbsup:
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
hey all and thanks for the info, What would be the best rev box to buy for my 2002 raptor? And to sf23...The quad runs like normal as far as idol but when given gas in any gear including neutral to a certain engine rpm it chuigs like its being limited in power ...then when gas is let off I have a normal idle...so im not sure if its the same issue but thanks for the input:D
 

·
Registered
Joined
·
204 Posts
Just buying a revbox is not going to fix the problem. You need to find out which one of your sensors is messing up or if your valves are screwed. If you unplug the clutch and parking brake sensor that should fix your problem unless it's your valves or your reverse sensor. If it's the reverse sensor your reverse light should be blipping on and off.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top