Raptor Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
Hey guys. Long story short- I got water in my stock fan so it quit working. Bought new spal aftermarket fan and it doesn't kick on when it needs to nor does it stay on. It will pulse on and off quickly sometimes but doesn't stay on. I hooked up some power to it so I know it works. Anyone have this problem? Sending unit bad or maybe thermostat? Thanks.
 

·
Registered
Joined
·
728 Posts
Don't know if the 07 is the same, but on my 06 there was 2 bullet style connectors under the seat. They were not fully seated, causing intermittent fan operation. Just a thought.
 

·
Registered
Joined
·
2,971 Posts
The Spal fan Overloads the OME circuit breaker(which is wrapped up in the harness) this causes the fan to cycle and the bike WILL overheat...

Search "warning Spal fan" or something like that , i did a write up about 2 years ago on them and how to rewire
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #4 ·
Awesome info. Thanks guys. Now i can finally get this thing working! You guys r awesome (saying that in hopes this fixes the problem ;) ) !!!
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Any updates?
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #6 ·
Not yet. At work currently. Going to the Home Depot after work to get some wire and fertilizer. Hopefully have it fixed by tonight.
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Good luck
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #8 ·
http://www.raptorforum.com/forums/showthread.php?t=59669&highlight=spal+relay


This link saved my life lol. This is exactly what I did and it works perfect. Thanks again dl700 for posting this DIY. The fan is awesome btw. I would recommend it to anyone who wants to upgrade your fan to keep your quad cooler or if your stock one went out. It blows a significant amount of air compared to the stock fan.
 
1 - 8 of 8 Posts
Top