Raptor Forum banner

1 - 20 of 22 Posts

·
Super Moderator
Joined
·
2,702 Posts
Discussion Starter #1 (Edited)
I have been meaning to get this video up, but I was waiting on permission from MSDpowersports and FCI to use their logo's in the video.

So here it is, sorry about the lame music, but I had to use something without copyright infringements.

I hope some find it interesting and maybe a little informative, if you have not done an install of either part as of yet, please ask questions, I and others that have done the install can try to answer them for you.

 

·
Premium Member
Joined
·
4,191 Posts
Nice video! Will help a lot of people I'm sure.
 

·
Super Moderator
Joined
·
2,702 Posts
Discussion Starter #5 (Edited)
Thank you... It runs really really well. It has a much smoother power throughout the gears, slightly more top end and a lot more torque.
It is like riding a new bike, sounds awesome and you can hear the intake also. I am going to tweak my maps a little just after I learn how to make a copy of the custom map it came with.
I am well happy with the cash I put into it, puts a smile on my face every time I start her up!
 

·
Registered
Joined
·
1,064 Posts
where was this video when i didnt know what the hell i was doing about 4 yrs ago :D Great vid and it will help alot of people
 

·
Registered
Joined
·
2,121 Posts
Thank you... It runs really really well. It has a much smoother power throughout the gears, slightly more top end and a lot more torque.
It is like riding a new bike, sounds awesome and you can hear the intake also. I am going to tweak my maps a little just after I learn how to make a copy of the custom map it came with.
I am well happy with the cash I put into it, puts a smile on my face every time I start her up!
Yeah there's nothing like the startup of a raptor with duals
 

·
Super Moderator
Joined
·
2,702 Posts
Discussion Starter #12
Hey Ray, gladly will do that. I was thinking about removing the MSD and doing another install of it and getting some better footage. I did not get enough of the install of the Blaster itself.
I will get that video up for you :) Thanks again for your kind words and your assistance.

Dean
 

·
Super Moderator
Joined
·
2,702 Posts
Discussion Starter #13
Just a heads up on this... if you are installing this unit with an aftermarket exhaust. Please check the clearance of the pipe and box. I have a pretty good melt on mine because my Exhaust was on before my box, I did not check it due to thinking it would be fine.
 

·
Registered
Joined
·
265 Posts
Dean, I should have told you about the pipe and box clearance but its been so long I forgot all about it. I took a heat gun to my box before I installed it, pushed it in a little and let it cool. Clears just fine now. My bad, sorry buddy!

Mike
 

·
Super Moderator
Joined
·
2,702 Posts
Discussion Starter #15
Dean, I should have told you about the pipe and box clearance but its been so long I forgot all about it. I took a heat gun to my box before I installed it, pushed it in a little and let it cool. Clears just fine now. My bad, sorry buddy!

Mike
No no... not your fault. I installed it and should have checked the clearance.. I undid my header on the right side and moved the pipe a little, got plenty of room now. Well there is enough lets put it that way! :)

Thanks for the replies...
 

·
Super Moderator
Joined
·
2,702 Posts
Discussion Starter #16
Dean, I should have told you about the pipe and box clearance but its been so long I forgot all about it. I took a heat gun to my box before I installed it, pushed it in a little and let it cool. Clears just fine now. My bad, sorry buddy!

Mike
HA HA... Just realized who you are.... lol.. Sorry Mike, bit slow on my part. :eek:
 

·
Super Moderator
Joined
·
2,702 Posts
Discussion Starter #20
Dude, I tried reading what you said. Unfortunately I can't read it because of your Avatar! It is hard to see anything but it.
 
1 - 20 of 22 Posts
Top