Raptor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter #1
Well after maybe 10 hours of riding on the mod's and brand new gytr heavy duty clutch kit, hinson billet basket etc etc the clutch is slipping terribly. I've maxxed the adjustment on the bar's, but this clutch cant be gone this quick? I'm no newb to clutch's so its not my riding but is there a adjustment that wil fix this?
 

·
Super Moderator
Joined
·
17,057 Posts
Pretty sure I've toasted mine as well, but it's lasted a while.

Have you tried adjusting the cable at the clutch end just above the cover? I found I had a loose locknut and it allowed it to work its way down until the clutch wouldn't disengage.

Check for a bound or stuck cable as well.
 

·
Registered
Joined
·
350 Posts
Discussion Starter #3
Maddog56 said:
Pretty sure I've toasted mine as well, but it's lasted a while.

Have you tried adjusting the cable at the clutch end just above the cover? I found I had a loose locknut and it allowed it to work its way down until the clutch wouldn't disengage.

Check for a bound or stuck cable as well.
I've even removed the small snap ring and brought back the lever a notch to see if I coudl get some more use out of it...
 

·
Registered
Joined
·
2,062 Posts
something not right. I've had a gyt-r clutch in a 70+HP raptor for over 2 years now, 1 of those as a full drag race season and its still good and not slipping. Did you pay attention to the order of the friction plates when installing it? Where did you put the 2 thicker friction plates?
 

·
Registered
Joined
·
350 Posts
Discussion Starter #5
CoalShedRacing said:
something not right. I've had a gyt-r clutch in a 70+HP raptor for over 2 years now, 1 of those as a full drag race season and its still good and not slipping. Did you pay attention to the order of the friction plates when installing it? Where did you put the 2 thicker friction plates?
Yamaha of houston put the clutch in for me... I wasnt daring enough to try and do it myself. I'm thinking about taking it back to them tomorrow and telling them whats up, along with my laptop to show them exactly what you just said. There were quite a few ppl at general sams this weekend drag racing (450' sand strip). After walking the 3rd or 4th 3 mod 700 :grin_nod: a guy on a brute 750 chipped, exhaust, intake wanted to race and out of the hole side by side (him in 4low) and in 3rd gear when it hit just felt sooooooo soft. Looked back thinking must be a huge roost and sure enough nothing..... he saw what I was looking at and let off and gimped it back.
 
1 - 5 of 5 Posts
Top