Raptor Forum banner
1 - 7 of 7 Posts

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #1 ·
I bought a HID kit in a group buy awhile back. They've always flickered or right one on left one off or vise versa. Somebody told me to get relays. Well here's my problem I suck at wiring stuff. So I need to know what type relay and how to wire them up. It's the single beam hid kit not a hi/lo kit if this helps. Thanks in advance for all the help fellas!
 

·
Registered
Joined
·
728 Posts
You can just buy a pre wired harness with a relay in it. It just makes the ballast have true battery voltage to it. Connect it to one of the ballast, a ground, and to the battery. I know ddm tuning has them for $15 bucks.
 

·
Registered
Joined
·
156 Posts
I just hooked my trail tech HID's into the stock wiring, but I did have to route a ground wire. the quick plug in that the stockers have 3 plug ins.. one is a ground.second is for low and the other is for high.. Get a 12 volt test light that you can clamp on to the frame for a good ground.. then turn on the light switch to high.. find the pin that has the hot wire.. Tap into that and wa la... no routing of other wires besides a ground and maybe the ones from your lights to the harness. Try connecting them directly to your battery with two jumper wires like a double ended alligator clips.. that way you can find out if your light ballasts are acting up or your just not getting a full 12 volts to your lights. BTW.. HId's do flicker a little bit upon light up. it takes a few seconds for them to warm up and then they get brighter. it sucks when your riding at night and you kill it and it takes em a few seconds to fire up again..
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #4 ·
Both lights work but at times it's only one light not 2 it sucks at night lol. But I'm not riding now I'm recovering from knee surgery. Just fixing all the small things until I can jump back on it. Thanks for the replies
 

·
Registered
Joined
·
1,064 Posts
i would check the bulbs connections and the wiring..maybe u just have a loose bulb or wire somewhere.
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #6 ·
I am I was just thinking if relays are cheap I might as well throw them on there while checking all the wiring and bulbs it couldn't hurt I don't think.
 

·
Premium Member
Joined
·
812 Posts
When I first got my hids it drove nuts how they did that but I was testing them with the quad off. I never had a problem with them if the quad was running and then I turned them on, of course they had to warm up but then no problems.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top