Raptor Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Good afternoon everybody! I'm kind of new to the forum but been a member for awhile but have been away working a lot but to the point i came back and bought a 01 raptor 660r for a few hundred bucks and the guy said there was a few minor problems with the quad, so i asked what the problems were and he said timing needed to be fixed and o rings on intake needed replaced and carbs needed cleaning, so i did all this and it started right up and would idle and rev but when i turned it off and tried to start it back up timing jumped so i replaced the timing chain and put it at tdc and she fired right up and reved all the way like she should, then the next day when i put the plastics back on it and try and take it out for a ride to make sure everything was good it wouldn't rev up at all?? and now its having trouble starting but the stater is good any ideas ive been on here looking up everything it could possibly be but i am completely stumped on whats the problem so any help would be great appreciated!! sorry for the long post and thanks ahead of time for the help!!
 

·
Master of the Electron
Joined
·
15,629 Posts
1) Please use some punctuation/periods... it is very difficult to read your one, gigantic run on sentence.

2) Please define with more detail the current problem you're having with starting... be verbose and desrcribe what you do and what it does or doesn't do.

3) does it run at all now? If so are you running into one of the rev limiters defined in "Common problems with the Raptor 660 explained" sticky at top of this section?
 
1 - 2 of 2 Posts
Top