Raptor Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
2,017 Posts
Discussion Starter · #1 ·
Ever since I installed the PCIII, Dr D full exhaust, and pro design k&N The damn thing is so hesitant to fire up. It takes once holding the starter for 2-3 seconds or holding it in for 2 seconds then letting go then pressing the starter agian. Please help as I am worried I made a mistake.
 

·
Registered
Joined
·
47 Posts
mine did that the first two or three time then it stop it was running way to rich
 

·
Registered
Joined
·
579 Posts
Double check the install of the PCIII and make sure you have the right map loaded.
 

·
Registered
Joined
·
2,017 Posts
Discussion Starter · #6 ·
Thx all, I got the original map from Jamie at Fuelmoto.com. I have sent him the info and he is going to revise it and try that and then maybe a couple of maps of the dynojet site. If not I will have to resort to the dyno for $300. I was getting worried that something was wrong with the ignition or something else due to it taking a little longer to start up.
 

·
Registered
Joined
·
177 Posts
Mine wasn't starting as quickly when the weather turned colder, I changed the plug and it pops right off now. Just another possibility besides the map.
 

·
Registered
Joined
·
177 Posts
No, it should start right up. You're right to chase down the problem and make sure everything is the best it can be. :thumbsup:
 

·
Registered
Joined
·
2,017 Posts
Discussion Starter · #10 ·
Jamie sent me a revised map and it feels better it seems to start after about 2 seconds on the starter button. The original map had too much fuel in the 0% throttle column. Now there is none. It took the popping on deceleration. If there is anyone who dynoed their DR D full exhaust I would love to compare my map. If anyone has one please PM me.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top