Raptor Forum banner

21 - 29 of 29 Posts

·
Registered
Joined
·
417 Posts
Full exhaust or just slip on? Sounds like you have an aftermarket piston in it too, forgot to include that?
 

·
Registered
Joined
·
417 Posts
There’s minimal chance the power commander was broken, I’m guessing that you just had a bad ground. How good did you check all your wiring before you pulled it off? There are two connectors on it that are very similar. You may have just plugged them in to the wrong ports
 

·
Registered
Joined
·
12 Posts
Discussion Starter #23
Full exhaust or just slip on? Sounds like you have an aftermarket piston in it too, forgot to include that?
Just a slip on pipe but I have a wiesco piston in it which was there when I bought it from someone.i checked all the clip ons before I took it off and took it to a yamaha dealer and he said it was bad the red lights didn t come on but the ground looks melted to the wire
 

·
Registered
Joined
·
417 Posts
Well that’s a bummer about your controller. Do you know why the piston had to be replaced?

Let me ask you this - You stated your bike dies after 10 sec. Does she start back up again easily and keep running afterward? And has there been any point where you could ride the bike without stalling out at idle?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #27
138271

Well that’s a bummer about your controller. Do you know why the piston had to be replaced?

Let me ask you this - You stated your bike dies after 10 sec. Does she start back up again easily and keep running afterward? And has there been any point where you could ride the bike without stalling out at idle?
Yes befor the commander went out it rode like a dream. I replace the rings only because I had to replace a head gasket so I said I might as well do everything else while I have it down. I will try to get another fuel controller and see if it runs back normal.
 

·
I may be getting older, but I refuse to grow up!
Joined
·
10,800 Posts
Just fix the wire on your controller and try it again.
 

·
Registered
Joined
·
406 Posts
View attachment 138271

Yes befor the commander went out it rode like a dream. I replace the rings only because I had to replace a head gasket so I said I might as well do everything else while I have it down. I will try to get another fuel controller and see if it runs back normal.
That's definately the problem then, stock map and too lean.
As Dezparado says too, maybe you can just repair the wire.
Maybe the PC is now fried and won't work even with the wire repaired, but it's worth trying.
 
21 - 29 of 29 Posts
Top