Raptor Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I was trying to install a new set of Burgard A-Arms. The fit and finish on the Arms are great. But the balljoints supplied with the arms have a little thicker threaded area and dont want to go in the spindle. Is there a special way to make them work? They are almost in but just not quite. I can see the threaded area come through the other side but not enough to put a nut on it. :(
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
I tried doing that. I might need to drill to end of the spindle a little. It would not affect the actual seating surface of the balljoint. Do you think that would be OK?
 

·
Registered
Joined
·
1,732 Posts
Don't drill anything, it may be you have the wrong joints. some times mistakes happen and you might have the wrong parts, I've had this happen several times with things being for the 660 and not the 700 or yfz parts and not the 700, even my elkas came with the wrong brass spacers when i first got them.
 

·
Registered
Joined
·
735 Posts
opps, didnt read close enough....yeh, some use VW bug tie rod ends...they need to be reamed, ...drill press and the correct size bit is what I would use...contavt the manufacturer to make sure....they should have tech support
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
I drill the small end with a 7/16 drill bit. I barelay had to remove any material. Did not touch the part that actually connected to the balljoints. It seamed to work pretty good. Also I had left 3 messages to the manufacturer about the problem. Thay have not contacted me yet.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top