Raptor Forum banner

1 - 8 of 8 Posts

·
2 Time (09,10) RF Fantasy FootBall Champ
Joined
·
655 Posts
Discussion Starter #1
I finally found a noise that has been bugging the crap out of me on my 700. When I am stopping or turning and the chain contacts the lower plastic roller, it is making a loud noise. It is like the bearing it out of it, but I have only had about three tanks through the bike.

Does anyone know how to fix this noise? :3question: I have tried applying grease, but it has not helped.

Thank You.
 

·
2 Time (09,10) RF Fantasy FootBall Champ
Joined
·
655 Posts
Discussion Starter #3
True that :thumbsup: , LTEs are on the list.

But until then.... I'd like to figure out how to fix this.
 

·
Registered
Joined
·
579 Posts
I know what you are talking about. It doesnt seem like the roller is turning. I havent spent the time to see what the deal is yet. I see there are after market rollers available with bearings in them. I guess I just need to pull it out and see what ther prob is.
 

·
Registered
Joined
·
314 Posts
hello all! first of all, awsome site :grin_nod:

secondly, on this subject i have about 30+ hrs on mine so far, and i just looked at the roller and found it will not turn whatsoever no matter how hard i tried.

but yeah, that noise is driving me crazy.
 

·
Registered
Joined
·
579 Posts
I was checking mine out the other day and it was gritty but turned. The roller has a bearing in it. It probably got wet or dirt or sand in it and is frozen. Pull it out and check the bearing and replace as necessary.
 
1 - 8 of 8 Posts
Top