Raptor Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
827 Posts
Discussion Starter · #1 ·
I put a full yoshimura RS3 Comp pipe on my bike, dynojet stage 2 kit, and put the pro design foam intake with billet adapter. the bike idles fine but as soon as i put it into gear and start to let out the cluth it seems as if im lacking fuel. it bogs down and sometimes stalls. if i stay heavy on the gas then it seems to be fine. but i would think it should be easier than that. when i do get it to take off and take it for a short ride it also seems as if im lacking low end power and the power doesnt seem to kick in till high RPMs. when i let off and decell it back fires and pops a few times. i pulled the plug and it seems to have carbon on it and the post in the middle looks as if its a light grey maybe white. i am running 146 and 148 mains and have the new DJ needles installed with the the clip in the 5th position out of six. im sitting in my garage with it apart so if you guys could chime in and help out that would be great.
 

·
Registered
Joined
·
2,786 Posts
those main jets are way too staggered. try 146/148 DJ mains.
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #3 ·
im sorry i mistyped. they are 146 and 148
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #4 ·
anyone?
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #6 ·
would my best bet be to raise the needle or up my mains?
 

·
Registered
Joined
·
1,674 Posts
It all depends on what is happening throughout your rpm range.

Mixture screw adjusts the idle mixture
Pilots control the 1/4 throttle mixture
Needle controls midrange
Mains controls top end

But then at the same time each has an effect in other areas of the power band. Get your idle and top end set then work to the midrange.

I'm trying to iron out my jetting as well, it takes some time and patience.
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #9 ·
my pilot jets are stock 22.5 and im assuming from doing a little looking around they go up im increments of 2.5. am i correct in thinking this? so i would need to try a 25 or 27.5? i can get them both. i was trying to get it going by tomorrow night as i ride the track on wednesday nights. ill have to see if they have them tomorrow.
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #11 ·
ok so i upped my pilots to 25 and the bike still ran like poop. well i went ahead and dropped the needle by moving the clip to the 4th position. seems to be rumming fine now except the Yosh is breathing fire. when i rev high it pops and shoots about a six inch to eight inch flame out the back. well i took it to the track not knowing this ,as i had my spark arrester on, and when i got there and took it off that when i noticed it. some of the guys there were telling me that i need to up my mains. (make it fatter (rich) if you will) i dunno it runs good now except the occational pop and a little fire :mad: ..... now what? anyone have the answer to my big problem. please chime in and give me any help you can.....
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #12 ·
just talked to dyno jet and the tech seems to think there is nothing wrong with flames out of the exhaust.... how can that be possible... well anyways i think im going to try and pull the carbs and but my stock pilots in and see how it runs. the guy from DJ seems to think im running a bit rich on my pilots. i guess it now trial and error at this point. ill try bumping down my pilots and see how it goes. and go from there maybe even a 1/4 turn on the fuel mixture screw might do the trick.... ill let yall know i appreciate all the help and if anyone has anything to add feel free to do so.
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #14 ·
seems to be fine since i dropped my needle down to 4th clip. i only get flames when i dry rev and rev hard (high rpms) i get a few small pops when i decell after getting on it....
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #15 ·
so i adjusted the valves and now she starts like a dream. a little touchy on the reving though. i pulled the carb and cleaned top to bottom. i will install carb tomorrow and take her for a test run.... also bumped my pilots back down to stock to see what differience it makes.
 

·
Registered
Joined
·
827 Posts
Discussion Starter · #16 ·
so after a bunch of tirla and error i decided to go down to the stealership and get mikuni mains as that is what yoshi recomends. so i jetted it as yoshi recomended and it seems like everything is decent except the verly low end and a bit of popping when i decell. im going to try and mess with it some more and try to richen up my FM screw and maybe up my pilots back to 25's. ill keep ya'll posted. if anyone thinks they have info that might help feel free to let me know.
 

·
Registered
Joined
·
135 Posts
yep try the 25's if not 27.5's pilots, your mains were fine, the DJ mains are better in my opinion the DJ 146/148 with the 4th clip on the DJ needles, only way I could get mine to run without popping and backfiring... :thumbsup:
 
1 - 17 of 17 Posts
Top