Raptor Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an '01' raptor with a k&n pro-flow , a white bros. slip on , and dyno-jet kit. It ran fine until my rev box went bad and I replaced it with a big gun rev box. I now have dead spot at about 3/4 throttle. I've tried many different things to correct the problem but nothing helps. I ride at 4500ft. elevation. I've tried mains from 140 - 148, needle position from the 2nd to the 5th groove, took carbs apart and cleaned them, stock exhaust, stock air filter, new gas, new spark plug, air box lid on and off, adjusted the valves. My mixture screw is 3 turns out. I've been thinking about trying Dial-a-jet. Are there any opinions about this or is jetting even my problem?

I'm also in the market for a complete exhaust system after I can figure out this problem. I'm thinking about a Yoshi titanium tri-oval or LTE duals ... any recomendations. The only place I ride is the dunes. Any help anyone can give me will be greatly appreciated. Thank You.
 

·
Super Moderator
Joined
·
17,058 Posts
Have you considered sending the cdi back and asking for a replacment?

I'm not a fan of Dial-a-jet and I don't think it'll solve your problems. 3/4 throttle is where the needles stop and the mains start. Try sticking your oem needles back in and see how they do, the change in timing from the rev box (if it changes anything at those rpms) and the taper of your needle may not be getting along.

If you've got the $$$ LTE's are very nice.
 
1 - 2 of 2 Posts
Top