Raptor Forum banner
1 - 20 of 69 Posts

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #1 ·
I blame white knuckle and the lack of R and D to find a proper mounting system for trail bike. My seat ain't hitting gas tank isn't pushing down on it. I've tried every trick I've been told. It's getting old it it was doing this on the old build also. I'm a wits end.

Just pushed it about a mile back to the trailer thank god I got trailer not truck. I'm calling White Knuckle Tuesday and give designer a earful. If this is a drag only part it should state on the site you buy from. If it's not the tube it's tb. I got tube on now tb coming off. I'm so mad I could literally attack the guy that makes these I really wish he living within a 100 miles I'd go to jail it'd be worth it to me. I waisted close to 600 for a part I can't use properly. I feel I've been robbed.*
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #3 ·
Soon as I hit a jump or get on a really rough trail the TB falls off the head or the intake tube comes off the TB. It's getting very aggravating. I can run wtfo on Dyno for hrs or ride streets no problem. Then soon as I get to the rough stuffs rocks small logs jumps it falls off throttle cable and fuel in holds it on bike. Now imaging I'm climbing a long 300-500 ft fairly steep hill this happens and bike dies I could get hurt very badly plus total my entire bike. It's nuts I've tried everything but buying a FCI intake mounting bracket that's next hope that helps. This is crazy I can't tighten any harder or I'll strip the clamps out it's nuts. I hope somebody can help me quickly I'll try anything.
 

·
Freak!
Joined
·
7,986 Posts
Spider, there are lots of trail, track guys pounding the whoops and hitting double and triple jumps with the 54mm/58mm TB with that intake tube (Preddy08, 4GUNZ, Troywcc for example). perhaps hit one of them up on how they overcame the issue?

Aaron
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #5 ·
Thanks Aaron I'm wanting this fixed badly. I'm so aggravated I can't think so I've left it a lone for now had to walk away was getting to upset. I feel I got a 15k paper weight in garage. Thanks again brother.
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #7 ·
I'm open to any and all ideas at this time. As I'm gonna try each one I haven't tried yet. I know there's something I haven't done yet or I'm screwing up somewhere not sure where but pulling fronts plastics and fuel tank again trying this all over again hopefully I over looked something but dint think I did. Something's gotta change though.
 

·
Registered
Joined
·
240 Posts
I'm open to any and all ideas at this time. As I'm gonna try each one I haven't tried yet. I know there's something I haven't done yet or I'm screwing up somewhere not sure where but pulling fronts plastics and fuel tank again trying this all over again hopefully I over looked something but dint think I did. Something's gotta change though.
Spider are you using the rubber adapter they sent you between the head and TB or did you modify the stock rubber to fit the new TB?
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #9 ·
The modified oem one. The rubber they sent was junk.
It did it again but I didn't go to trail rode up down street second and third hard bout ten times wheeling each gear letting front drop hard everything seemed fine. So I go down to this long alley that's full of huge pot holes a foot deep or more. Flew thru there twice end result was

I'm gonna burn her to the ground I can't handle this and who know what knew engine has sucked in WOW!!

THE PART SHOULD FIT WHY AIN'T IT? it's driving me outta my mind.
 

·
Registered
Joined
·
366 Posts
Does the plastic intake tube come with any brackets to hold it up? If not, the weight of the intake and filter are popping it off. I would change your oil to get any dirt out of the motor.
 

·
Premium Member
Joined
·
1,422 Posts
Did you put any spacers in between the rear mounts of your gas tank ? You usually need about 3/8ths to 1/2 inch spacers to keep the tank from hitting the fuel rail.....You may think your tank isn`t hitting the TB....but, on rough stuff your butt weight from the seat to the tank could be forcing the tank onto the TB and then....."somethings got to give"....lol.

If you spaced the tank up....forget this post....lol !


~ Sandaddy
 

·
Premium Member
Joined
·
3,801 Posts
Did you put any spacers in between the rear mounts of your gas tank ? You usually need about 3/8ths to 1/2 inch spacers to keep the tank from hitting the fuel rail.....You may think your tank isn`t hitting the TB....but, on rough stuff your butt weight from the seat to the tank could be forcing the tank onto the TB and then....."somethings got to give"....lol.

If you spaced the tank up....forget this post....lol !


~ Sandaddy
+1

Also I didn't like the stock boot when I was running my 52 or 54mm TB. I did what Lucky said and used a rupper piece that came with my Spectre filter and it worked great. I don't like the OEM one for the larger TB's. I used the rubber that came with my 58mm to mount the TB to the Head and haven't had any issues at all. I am hard on the tractor too with nothing coming off. It has been railed through the whoops with a strut on the rear. Also has been wheelied and jumped, haven't had it come off yet *Knock on wood*
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #13 ·
Does the plastic intake tube come with any brackets to hold it up? If not, the weight of the intake and filter are popping it off. I would change your oil to get any dirt out of the motor.
It came with a bracket that's about 1-12/-2" long and a 1/2" wide that bolts to top of the tube then to the bolt that hold front and rear plastics. The bracket sucks.
 

·
Premium Member
Joined
·
1,422 Posts
+1

Also I didn't like the stock boot when I was running my 52 or 54mm TB. I did what Lucky said and used a rupper piece that came with my Spectre filter and it worked great. I don't like the OEM one for the larger TB's. I used the rubber that came with my 58mm to mount the TB to the Head and haven't had any issues at all. I am hard on the tractor too with nothing coming off. It has been railed through the whoops with a strut on the rear. Also has been wheelied and jumped, haven't had it come off yet *Knock on wood*

+1 on the boot.....I have never used the stock boot on any of my aftermarket TB`s.....Kenz or WK.

Spider....I have ridden my bikes pretty damn hard and I`ve never had this happen with any of Eric`s WK TB`s or the Kenz units and my bikes are not "drag" only......Kinda hard to blame a "design" problem or R&D when so many others have not had the issues you describe. Eric is a good vendor and doesn`t put out anything that would be crap......He is one who has brought us all a lot of solid aftermarket products and I have always found him to be helpful.....just my 2 cents !

I`m sure you`ll figure this out.....Stay Kewl, Bro !


~ Sandaddy 8)8)
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #15 ·
It came off easier with the boot they sent. It would come off while tightening. It was just blue radiator hose. This has been a problem since it was a 734.
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #16 ·
+1 on the boot.....I have never used the stock boot on any of my aftermarket TB`s.....Kenz or WK.

Spider....I have ridden my bikes pretty damn hard and I`ve never had this happen with any of Eric`s WK TB`s or the Kenz units and my bikes are not "drag" only......Kinda hard to blame a "design" problem or R&D when so many others have not had the issues you describe. Eric is a good vendor and doesn`t put out anything that would be crap......He is one who has brought us all a lot of solid aftermarket products and I have always found him to be helpful.....just my 2 cents !

I`m sure you`ll figure this out.....Stay Kewl, Bro !


~ Sandaddy 8)8)
I shouldn't have bashed WK like that I was mad after having this happen over and over. Then getting burnt on hot engine trying fix. My emotions got the best of me at that time.
 

·
Premium Member
Joined
·
1,422 Posts
It came with a bracket that's about 1-12/-2" long and a 1/2" wide that bolts to top of the tube then to the bolt that hold front and rear plastics. The bracket sucks.

Sorry....Not trying to be Eric`s cheerleader....but, I have 2 bikes with the WK intake tube and the bracket you describe....and had it on 2 other bikes that I`ve sold.....and it`s a solid intake and I had no problems with the support bracket.

Soooo.......Did you space up the gas tank in the rear ?


~ Sandaddy 8)
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #18 ·
Yes on spacing gas tank about a 1/2 inch with washers.
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
Discussion Starter · #19 · (Edited)
Working on seat now. Email me your cell number so I can send you pic if what I'm bout to grind of seat. [email protected] it's the part that goes user sub frame up front I'll post pic here.
Take just skinny part figure touching off or all of it?

If possible post a pic with everywhere I should clear the seat please. If not try to explain as that's only place I see that touches but once I'm in it I can't see and I'm sure seat most likely compresses under 240lbs and bumps. So here's to hoping that's the fix gas tank spaced part of seat cleared lasted longer but still popped off again. Anybody else have an idea that hasn't yet been posted please shoot will try anything and everything.
 

·
#327 "After Hours"
Joined
·
1,130 Posts
Why are you using the stock clamp setup? Use a clamp with a tbolt in it. If I can boost my old car to 28lbs and not blow the intercooler apart with them it sure as hell can hold a few bumps and what not.
 
1 - 20 of 69 Posts
Top