Raptor Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
1,346 Posts
Discussion Starter · #1 ·
ok i have new 07 rappy. and have about 6-8 hours on it.. now when i first fire it up it runs like crap and looks like it blows a little black smoke. then when i ride it , it likes to back fire thru the exhaust when you shift from 1 to 2 gear. the valves havent been adjusted. also the exhaust is getting a raspy sound to it is this normal. and how often should the fan come on. since ive had it i hear it comeon once and i have checked the connectors under the seat..... and you would think the first valve adjustment should be done under the warrenty and not out of pocket.. please help. and i warm it up for about 1-2 mins till i ride it..
 

·
Registered
Joined
·
728 Posts
try disconnecting the battery to reset the computer. if that doesn't work i had a problem with mine that when you would start it when cold it would puff black smoke and was hard to keep running. i pulled my spark arrestor out and it started fine and didn't have any problems with it. sounds like its running rich, might want to try a new plug.
 

·
Registered
Joined
·
21 Posts
ok the raptor needs to be completely warmed up before riding. 1-2 minutes is not cutting it. start the enigne and let it warm up for 5 minutes and DO NOT rev the engine just let it warm up. since you have been warming up your machine like that you probably fouled the plug go get a new one at the dealer and change the way your warming it up and your problem should be gone.
 

·
Registered
Joined
·
1,346 Posts
Discussion Starter · #4 ·
thanks guys. didnt know the rappy was touchy about warmups. ill get a new plug this weekend...
 

·
Registered
Joined
·
368 Posts
sikraptor700 said:
mines not touchy, I start it and slam the throttle and ride, no issues
agreed - my white one starts up and i ride the hell outta it.
 

·
Registered
Joined
·
71 Posts
one of the purpose of fuel injection is instant start in any situation. Any fuel injected motor can be treated like a car, start and go. It is always best to let any motor circulate and warm up the oil to increase longevity or the motor, but you should not be running bad at start up. if you do or get anything for your bike you should get one of the many fuel injection computors on the market because even a stock bike can gain from adjusting the fuel curve especially if you have access to a dyno. Dyno tuning any engine reguardless of modifications can always release hidden power.
 

·
Registered
Joined
·
21 Posts
ok the raptors computer does not start fine tuning the motor until it is warmed up. fuel injected motors run rich until a certain temperature is reached and go into a constant adjustment cycle to keep the motor running correctly. if you dont let the motor warm up it runs rich and fouls the plug easily and causes hard starting and popping, some bikes get affected more than others. its always a good idea to let it warm up just my 2 cents
 

·
Registered
Joined
·
91 Posts
I have to let my blue one warm up to keep it from eating plugs and just so all of you white 700R owners don't get your hopes up, my brothers white one eats plugs also unless warmed for 1-2mins. Maybe it has somthing to do with elevation? I am just about at sea level in the south east.
 

·
Registered
Joined
·
1,732 Posts
I've got a white one too, and I used to fire then rip then recently I started eating plugs every weekend. Then it got to where i couldn't even ride because it was fouling plugs on start up. at first i though it might have been my dobeck, I got so frustrated till after a little raptor forum search button use, I learned about the tps sensor. I swaped mine out with a raptor from the local yamaha store as a test a with a little fine tunnning of the tps it cured all my woes. Now just as a precaution i let it have a 4-5 min warmup before ride. The service manual shoes how to test your tps with a volt ohm meter. Elvation shouldn't make much of a difference I recently whent from Salt lake at 4500 ft to Guam at 0 feet and after the new TPS I'm back to using the same settings I had in salt lake
 

·
Registered
Joined
·
1,346 Posts
Discussion Starter · #13 ·
well i replaced it with a ngk iridium plug, and like magic... all problems solved, now i will warm up for at least 5 mins..
 

·
Premium Member
Joined
·
3,862 Posts
I usually it warm up for about 3 to 4 minutes unless really cold. And yesterday i was going around the horseshoe i live in and I got on it till 3rd gear and let off the gas and it backfired and popped alot. So i got up today and wanted to hear it without the spark arrestor. With it out it seems to idle smoother and it popped like once when i let off after getting on it till 3rd. I havent check my plug yet. But why is it popping with the sparky in and hardly not at all with it out?? Stock air filter and lid is on also. It has about 12 to 15 hours on it.
 

·
Registered
Joined
·
1,732 Posts
Pull your plug and give it a good cleaning then let your rappy warm up for 4 or 5 min and then when you get on it go for a min or so at half throttle, before you go rippen. See if this helps The rappy has a startp up warm up sequice that it goes through. It might not seem to cold out but ya never know.
 

·
Registered
Joined
·
988 Posts
So if ya let it warm up for 3-4 mins at idle and then cruise for a min or so should it be alright warmed up then shut off for a Dead Engine start Race?.......just need the warmup time cleared up for when i begin Racing from a Dead engine start....thanks
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top