Raptor Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
I have been working on and trying to figure why my 4wheeler is doing this for a while now. When i take off on my 4 wheeler the 1st, 2nd, and 3rd gear will hit rev limiter QUICK and its like im not going anywhere.

now for the history of what i have done:

i have changed the sprockets and chain to a 16T in front and stock in back to get longer gearing. i have put a wiseco piston and rings in it, along with a hotcam cam. There is no leaks. The clutch was just replaced and it was doing it before and now after still. The stater went out and the mechanic replaced the pulser unit only. there is a tick in the motor and the cam chain needs to be replaced but is not at the point of replacement quit yet. the valves do need to be adjusted probably. i have put a jet kit in the bike to compensate the new top end. i have a k&N air filter. I have a FMF exhaust.


whats weird is the bike ran good as can be after the top end was done and then one day i went out there and it would not start so i took it in the shop and it was the pulser unit. so the mechanic replaced it and it ran. he said it ran fine on his track but when i get it back its not been running right ever since.

is there anything i can check to see whats wrong. I am thinking its my stater not putting the right power out or my cdi box is bad


Thanks for the help in advance.
 

·
Registered
Joined
·
7,128 Posts
So, lets say you start in 2nd, take off... and go to third and try to shift into 4th and it revs up and then what:confused: I dont get it?
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #3 ·
when i take off and hit the throttle it will hit the rev limiter quick before i shift then i shift and it will rev back down normal then pick up a little speed and then rev back to the limiter. it will do that in 1st, 2nd and 3rd. once to 4th it will act right but i have lost power it seems like in the lower gears.


it seems like i have short gearing ratio and im going through 3 gears quick as h3ll.
 

·
Registered
Joined
·
113 Posts
when i take off and hit the throttle it will hit the rev limiter quick before i shift then i shift and it will rev back down normal then pick up a little speed and then rev back to the limiter. it will do that in 1st, 2nd and 3rd. once to 4th it will act right but i have lost power it seems like in the lower gears.


it seems like i have short gearing ratio and im going through 3 gears quick as h3ll.
did you put on smaller tires? just asking, it will make a big difference and kill your top end.
 

·
Premium Member
Joined
·
354 Posts
well you quad doesnt have a rev limiter. what there is is a sensor that linits rpm when the pbrake is on but the sensor goes bad sometimes and limits the rpm. just unplug it and youll be fine
 

·
Premium Member
Joined
·
354 Posts
also noticed you rejetted. what did you do, you shouldnt have needted to change much with just a piston and cam. is it bogging? becaust that could mean its too rich
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #9 ·
also noticed you rejetted. what did you do, you shouldnt have needted to change much with just a piston and cam. is it bogging? becaust that could mean its too rich
No its not bogging. Its not running rich cuz I smell no gas. I put the next size up from what it had in it before the jet kit. I had this problem before the jet kit and still have the problem
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top